WOPI: Application server does not match this AppProvider

Hi there, i am currently trying to attach an existing OnlyOffice instance to an oCIS Setup without Docker.

Using the following env, it complains about the mentioned missmatch in the headline:
unable to register services: rgrpc: grpc service appprovider could not be started,: Application server at https://wopi.ocisdomain.de does not match this AppProvider for OnlyOffice


The Wopiserver instance itself for now only has configured its domains and loglevel and otherwise is not yet touched.

I was able to find similar issuereports but nothing that was of direct help so far… .

Embarassing, already (partially) solved. I didn’t spot requests made to the OnlyOffice server and was assuming it failed before trying. But enabling wopi-support (and allowing the additional domain) in OnlyOffice already fixed the problem – except that it still just downloads files instead of opening the editor.

I have noticed that app-registry.yaml and tried to add it into the config directory as well as pasting it in the main config. It’s either not recognized or something else is wrong. I have not spawned an additional ocis appservice due to conflicting ports.

In the ocis.yaml i of course also adjusted each entry from the Docker example. Such as

  - mime_type: application/vnd.openxmlformats-officedocument.wordprocessingml.document
    extension: docx
    name: Microsoft Word
    description: Microsoft Word document
    icon: ''
    default_app: OnlyOffice
    allow_creation: true

oi, not allowed to edit anymore… anyway, learned that there was a rightclick which tries to open with onlyoffice but receives an 500. lets see.

Edit: i made it … at least partially. Wopiserver was updated with an adapted config from the docker example and realized that i need to actually allow the wopi url, not the owncloud url in onlyoffice. However the create option in web still downloads, but it works on rightclick.

Wow, what a journey…

Getting a 500 does not sound good, please make sure to push an issue report to Issues · owncloud/ocis · GitHub so that it can be fixed.


Yea, if given the chance, i tend to discover all the ways one shouldn’t deploy something xD – but hey, it appears to be working now.

Sure, once i am certain that i am not the one to blame and i fail to get help on the forum or rocketchat, i will file an issue :slight_smile:

We’re you able to resolve this?