Xls or docs Files are not able to Save in OC 8.1, even after Scanning


I have Code VM, i have placed few files and tried to file scan and allow 0755 to directories and 0644 to files in Data Folder. But still im unable to save the files sometimes, it works and some its wont.

Any Idea., how can successfully save the files, it seems problem for all.

Thanks in Advance.

consider using external storage if you want to modify files directly, more details can be found in this FAQ:


Thanks for ur reply, My problem is different.
Whenever I place file on datadir in admin/files.

I empty oc_filescache and oc_fileslock and

run file scan PHP occ files:scan admin account.

Then give wwwrun:www to admin files with 755 to folder and 0644 to files. Then I restart the server, go to owncloud webpage try to open and edit and save the files and close, when I open same file I don't see the changes made and saved.

I tried oc 8 and oc 9, none of them able to get this problem resolve, is anybody able to save the files successfully before ???

You are not supposed to make changes there at all. It's not a real cache, it's more a file index and all sharing and syncing information is references to this index. If you delete and rebuild it all this information will become useless. All files/folders in the main data-storage should only be accessed via ownCloud (webinterface or webdav) but not on the filesystem of the server directly.

Sure thanks I will keep that in mind.

But if I wanted to upload data, I have to upload from back end only, and this I can't see files on owncloud page when I login, for that I read somewhere to empty n file cache. I totally agree wil not touch those again. But

How do I upload data again n make this show on owncloud page.
How do I easily save and see the changes next time I open same file.
How do I search quickly, it takes ages to find anything.


I still don't know how you are upload files. Through an owncloud backend (oc-client/webdav/webinterface). For anything else, please use the external storage feature as stated in the FAQ posted before.

To upload data from back end I'm using winscp to transfer files from Windows to data directory.

WinSCP also supports WebDAV, so you won't need to put it directly into the data/-directory. If you prefer it for better speed or whatever, then please use a different system folder and make it accessible via external storage feature.

Thank you soo much.

Here the problem i dont have in uploading the files in admin/files locations. FOllowing logs i see

Error PHP PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/php_mysql.dll' - /usr/lib64/php5/extensions/php_mysql.dll: cannot open shared object file: No such file or directory at Unknown#0 2016-11-12T09:19:13+00:00

Error PHP DateTimeZone::__construct(): Unknown or bad timezone (UTC+04:00) at /mnt/www/htdocs/elitecloud/lib/private/log/owncloud.php#71 2016-11-11T12:02:15+00:00
Debug no app in context Loaded WOPI Token record: {"id":"152","owner_uid":"admin","editor_uid":"admin","fileid":"424338","version":"0","path":"/ACE Home Folder/Management/2015 Password Updates.xlsx","token":"0v2duyZZHeg5z4lo1HMQWXPgn07jgTfu","expiry":"1478867531"}. 2016-11-11T12:02:15+00:00
Debug richdocuments Getting contents of file 424338, version 0 by token 0v2duyZZHeg5z4lo1HMQWXPgn07jgTfu. 2016-11-11T12:02:15+00:00

Error PHP DateTimeZone::__construct(): Unknown or bad timezone (UTC+04:00) at /mnt/www/htdocs/elitecloud/lib/private/log/owncloud.php#71 2016-11-11T12:02:14+00:00
Debug richdocuments File info: {"object":{"OC\Files\FileInfodata":{"fileid":424338,"storage":"home::admin","path":"files/Home Folder/M/2015 Updates.xlsx","parent":"95457","name":"Updates.xlsx","mimetype":"application/vnd.openxmlformats-officedocument.spreadsheetml.sheet","mimepart":"application","size":23145,"mtime":1451242617,"storage_mtime":1451242617,"encrypted":false,"etag":"5379c56defa4598647517b90c7064cd5","permissions":27},"OC\Files\FileInfopath":"/admin/files/Home Folder/M/2015 /Updates.xlsx","OC\Files\FileInfostorage":{"object":{"OCA\Files_Trashbin\StoragemountPoint":"/admin/","OCA\Files_Trashbin\StoragedeletedFiles":[],"OCA\Files_Trashbin\StorageuserManager":"object","storage":"object"}},"OC\Files\FileInfointernalPath":"files/Home Folder/M/2015 Updates.xlsx","OC\Files\FileInfomount":{"object":{"storage":"object","class":"\OC\Files\Storage\Home","storageId":null,"arguments":[],"mountPoint":"/admin/","*mountOptions":[],"OC\Files\Mount\MountPointloader":"object","OC\Files\Mount\MountPointinvalidStorage":fa

I have problem of files not saving data, you are driving me to something else.

How easily i can upload data into Owncloud Data Dirctory without Winscp.
How do I easily save and see the changes made next time I open same file.
How do I search quickly, it takes ages to find anything, is there any search ap

Can you please let know how can i resolve this.


in this thread you're currently mixing various problems/issues (upload, search and logfiles) and it seems also you don't want to read the info you already got provided. For this reason i'm closing this thread as this thread is just a hughe mess.

PLEASE read the following FAQ to understand how files can be uploaded from the backend to oC. For the other issues (search and logs) please create a new thread for each issue.