10.0.9 memory-based locking with APCu but warning still present


#1

Hello,
On a debian 9.5 (PHP 7) I’ve installed apt-get install php-apcu and enable it (I can see version 5.1.8 is enable in phpinfo). I’ve add ‘memcache.local’ => ‘\OC\Memcache\APCu’, to config.php, but I’m still getting the warning :
Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information.

I’ve google a lot but still can’t understand why I still get this warning.

Any advice ?

Thx a lot!

Steps to reproduce

apt-get install php-apcu

add ‘memcache.local’ => ‘\OC\Memcache\APCu’, to config.php

Refresh admin page

Expected behaviour

Warning about memory-based locking should disappear

Actual behaviour

Warning about memory-based locking is still present

Server configuration

Operating system: Debian 9.5

Web server: apache2 2.4.25

Database: mysql

PHP version: 7

ownCloud version: (see ownCloud admin page) 10.0.09

Updated from an older ownCloud or fresh install: Updated

Where did you install ownCloud from: https://owncloud.org/

Signing status (ownCloud 9.0 and above):

No errors have been found.

The content of config/config.php:

{
“basic”: {
“license key”: “REMOVED SENSITIVE VALUE”,
“date”: “Wed, 08 Aug 2018 09:15:37 +0000”,
“ownCloud version”: “10.0.9.5”,
“ownCloud version string”: “10.0.9”,
“ownCloud edition”: “Community”,
“server OS”: “Linux”,
“server OS version”: “Linux vps307921 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64”,
“server SAPI”: “apache2handler”,
“webserver version”: “Apache/2.4.25 (Debian)”,
“hostname”: “137.74.173.129”,
“user count”: 11,
“user directories”: 11,
“logged-in user”: “admin”
},
“config”: {
“updatechecker”: false,
“instanceid”: “ochqrxit2b2w”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“137.74.173.129”
],
“datadirectory”: “/var/www/owncloud/data”,
“overwrite.cli.url”: “http://137.74.173.129/owncloud”,
“dbtype”: “mysql”,
“version”: “10.0.9.5”,
“dbname”: “owncloud”,
“dbhost”: “localhost:80”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_smtpmode”: “smtp”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“theme”: “”,
“loglevel”: 2,
“maintenance”: false,
“mail_smtpauthtype”: “LOGIN”,
“mail_smtpauth”: 1,
“mail_smtphost”: “REMOVED SENSITIVE VALUE”,
“mail_smtpport”: “465”,
“mail_smtpname”: “REMOVED SENSITIVE VALUE”,
“mail_smtppassword”: “REMOVED SENSITIVE VALUE”,
“mail_smtpsecure”: “ssl”,
“trashbin_retention_obligation”: “auto”,
“memcache.local”: “\OC\Memcache\APCu”,
“enable_previews”: true
},
“integritychecker”: {
“passing”: true,
“enabled”: true,
“result”: []
},
“core”: {
“backgroundjobs_mode”: “cron”,
“installedat”: “1523489909.1939”,
“lastcron”: “1533719702”,
“lastupdateResult”: “[]”,
“lastupdatedat”: “1533719291”,
“public_files”: “files_sharing/public.php”,
“public_webdav”: “dav/appinfo/v1/publicwebdav.php”,
“shareapi_allow_public_notification”: “yes”,
“shareapi_allow_social_share”: “no”,
“vendor”: “owncloud”
},

}
Are you using external storage, if yes which one: local/smb/sftp/… No

**Are you using encryption:**no

Are you using an external user-backend, if yes which one: No


#2

You have to enable file locking.

What you have done is enable memory cache.

File locking is enabled with this line:

'filelocking.enabled' => true,


#3

Hello Dimitry,
Thx for your answer.
I’ve tried to add ‘filelocking.enabled’ => true, to my config.php, but warning is still present.


#4

have you tried reloading the apache server? This might be a caching warning message what you currently see.


#5

Hey,

additionally to the php-apcu i’m also seeing a php-apcu-bc extension on Debian. Maybe this needs to be installed / enabled as well?


#6

Hello,
Yes, I’ve tried with a restart from apache. I finally solved the problem by using redis.

Thx for your answers anyway.


#7

Ah, yes. From what i know “memcache.local” is something completely different to the “Transactional file locking”. You might want to have a look at the documentation of ownCloud which seems to explain that “memcache.locking” and redis needs to be used:

https://doc.owncloud.org/server/latest/admin_manual/configuration/files/files_locking_transactional.html?highlight=transactional