2.9.0 can't add sync folders

Error message displayed when adding connection:
The folder /home/user is used in a folder sync connection! Pleas pick another one!

All started after client update, bellow each of the folder syncs error message was displayed that this folder is used in another sync connection with advice to delete and recreate connection.

Deleted all sync connections and now I can’t add them back. Removed all content of .config directory but problem still persists.

Setup screen: Screenshot-20210910095223-961x761.png - Google Drive
Adding first folder: Screenshot-20210910095419-821x762.png - Google Drive

What files are currently in the home/ask/owncloud ? (Especially hidden files)

total 1,8M
drwxr-xr-x 4 ask ask 4,0K wrz 10 09:34 .
drwxr-xr-x 168 ask ask 12K wrz 10 09:57 …
drwxr-xr-x 3 ask ask 4,0K lis 15 2018 graphics
-rw-r–r-- 1 ask ask 1,6M wrz 10 09:33 .owncloudsync.log
-rw-r–r-- 1 ask ask 148K lut 6 2020 ._sync_02c1cd2c19a6.db
drwxr-xr-x 2 ask ask 4,0K lip 21 13:35 temp

But there is also error when I try to add any other folder even empty new one i.e /home/ask/test.

Okay, please remove .owncloudsync.log and ._sync_02c1cd2c19a6.db , then try again

1 Like

Removed .sync_* files from all synced dirs also from parent /home/ask and it seems to be working now, thanks!

1 Like

I have a similar problem since the update. I am a Windows Desktop user and at the moment files are not syncing at all. On all my computers, I am getting the following message:
„Multiple Accounts are sharing the folder d:\owncloud. This configuration is known to lead to dataloss and is no longer supported. Please consider removing this folder from the account and adding it again.”
However, I did not share this folder, this is the local folder on 3 PCs. In the web client this folder is also not shared.
I already deleted the .sync files as well as owncloudsync.log. I also did a reinstall on all PCs and changed the folder. Nothing happened.
I have not access to the server side of the cloud.

Issues here too after upgrading to 2.9.0 on an Intel Mac. Syncing came to a halt.

Downgraded to 2.8.2 (after removing all preferences, since these also seemed to cause troubles) and now everything is back again (on version 2.8.2 that is).

Something seems to be broken with 2.9.0.

Same here, looks like a cosmetic bug, as it does not affect the sync functionality itself (at least in my case).

Have the same problem as Kai.
In addition, my Windows Explorer behaves very sluggish or does not load the file structure at all. Especially in the OwnCloud folders. When I quit the OwnCloud client, Windows Explorer works without problems.

After a rollback to 2.8.2 I have no problems at all.

So far there are 3 forum threads describing this bug. Here is the code that causes it: https://fossies.org/diffs/ownCloud/ Search for “Multiple accounts are sharing the folder” text entry. Apparently the code was introduced in 2.9.0. Is there a way to report to the developers?

@Kai1 @vco1 @RandomITGuy your issue is different from the original problem in this post. See my comment in the other thread: Multiple accounts - #21 by michaelstingl

I’m having the same issue. I’ve tried deleting .owncloudsync.log from the root folder and also .owncloudsync.log from the Dropbox folder that I’m trying to add (it used be a synced folder but I removed it after getting the error message). But I’m still getting the error when trying to add the sync.

I also have these hidden files in the root folder:

Anyone know if I should delete these hidden files as a fix? Is it safe?


This should already be gone when you quit the client.

Are there other *.db files in your sync folder? They should be removed first.

If you delete those files when the client doesn’t run, they’ll be re-created at the next start. You’ll only use some settings, like de-selected folders etc.

When I quit the client, these hidden files don’t go:


So I deleted them anyway and you’re right, it just had to rebuild the selected/deselected folders. No big deal, just a bit of time to sort. However, problem still persists, I still get the error message when I pick a folder “The folder XXXXX is used in a folder sync connection! Please pick another one!”

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.