9.1.6 app not functional

9.1.x

#1

Hi,

after update from 9.1.5.2 to 9.1.6:

any solutions? Thanks.


#2

Forget the app store, it's broken. Get your apps directly from github.


#3

thanks, I restore 9.1.5.2


#4

Would you care to expand a bit on that?
( I try to maintain https://wiki.mageia.org/en/OwnCloud despite i dont use ownCloud very much. )


#5

Some of the apps presented within OC 9.1 cannot be installed, due to bad or defect links.


#6

Is there a bug report on that?

I dont use apps, but i have upgraded several iterations from 8.x and now 9.1.6 and all listed in the owncloud interface could be activated, and downloaded upgrades OK.


#7

Bugs to the app store can be filed here: https://github.com/owncloud/appstore-issues/issues

The app store had a few issues and the Nextcloud fork quickly wrote a new app store. Finally, ownCloud also rewrote the app store and now published a new "marketplace" ownCloud 10 and newer. So on the old app store, I don't expect a lot of changes/fixes. For the apps it might be up to the developers to keep publishing their apps for current releases (some maintainers focused on Nextcloud and unfortunately neglect the ownCloud version). Perhaps you can ping some developers or help getting it published or you just get the apps manually.


#8

@tflidd is right, the old appstore won't be maintained any longer (and will be shut down soon) and developers are asked to publish their apps on our new ownCloud marketplace.
Anyhow, for problems with single apps please refer to the developer directly.


#9

Hi,

I update this post because on my test server, I've updated to 9.1.6. I'va got a message of integrity error.

In the details, I have the following :

- calendar
_ - EXCEPTION_
_ - OC\IntegrityCheck\Exceptions\InvalidSignatureException_
_ - Certificate has been revoked._

The warning is only on the calendar which is part of Owncloud Core if my memory is good. I don't use an alternative claendar app that can be found in the old store.

The calendar is working but this warning distrub me.

So what should I do with this. Use another calendar app from the new market place or wait for the certificate to be updated ?


#10

Very interesting, thank you for pointing out this. I have planned to upgrade to 9.1.6 within the next few days...


#11

Hi christianlx,

please refer to https://github.com/owncloud/calendar/issues/800 where you will find a solution for the "Certificate has been revoked" warning.


Integrity check failiure after upgrade
#12

I confirm the solution :

  • disable calendar 1.4.1 as admin
  • edit config.php and add 'appstoreurl' => 'https://marketplace.owncloud.com/api/v0',
  • rename the apps/calendar directory to calendar.old
  • restart httpd service
  • install the new 1.4.2 calendar app that appear in Productivty section
  • it's working and datas are here

Nevertheless, too bad that this component has not been upgraded directly in 9.1.6 patch....