Access ownCloud server outside LAN

tl;dr - check your ISP is not blocking ports 443 (and/or 80)

I have solved this problem, but thought I would post here in case someone else has the same issue. The topic was covered in this old post

I had a functioning ownCloud server, working fine on https://localserver/owncloud (from LAN). Despite having correct port forwarding configuration I was unable to connect to the server from outside the LAN. I was able to ssh into the server, and was running a minecraft server that worked fine... so it was bizarre.

After breaking the server in a variety of ways mucking around with numerous settings and config files I discovered the issue was port blocking by my internet service provider, which I was able to turn off through the settings on their website:

. Problem solved.