Access to admin panel leads nowhere but apache excesive CPU load

9.1.x
webserver_issue

#1

Hi,

I'm facing an issue with my personnal owncloud setup (using raspberry pi 2).
Everrything was working fine until a few days.
Last week I noticed some files were impossible to sync with server (sync from on computer, and failed to be sync a second one). The second PC got errors like "sync canceled" or connection lost... I updated everthing since (Firmware and OS) and did not got any such thing yet. So I considered this as solved...

But then I just found myself unable to reach the admin panel. Once I logged in as admin, if I click on admin panel on the menu, the page loads forever and my server load start rising and do not stop until server got totaly unusable or before I restart apache.
It behaves like an infinite loop or I don't know.
I have quite a big cloud (200GB). Could this be a raison for this ?
I can browse through all my files on the web interface, the admin panel is really the only thing causing troubles...

Thanks for your help.
Tristan

I use OC 9.1.0 on raspbian.
The raspberry does not run on the SD card but on an external hard drive.


#2

Hi,

could you look in the owncloud.log and look for an error?

the log file should be in the owncloud directory /data


#3

Hi,

Thanks, you solved my issue indirectly =).
I tried to get last lines of my owncloud.log file, but the file seems to be corrupted, I had to hard reboot the server (unplug it...) to get it back from overload, the file must have been corrupted at this moment. There was no EOF.
By the way, the file was 215MB, maybe a bit huge for my poor raspberry...
I renamed it and created an empty one, and I was then able to access the admin interface.
Since the admin panel show logs, it may hangup if the log file is corrupted. I'll remember this.

Thanks for your help.
Tristan


#4

Glad I could help you out :slight_smile: And I learned something too - corrupted logfile - no admin interface