Accessing ownCloud from a private address

We have an ownCloud solution which we have had for several years, but it hasnt been used for a while till now, and we now need to use it, but we have a problem. The administrative web page is on one class C range and is available to us as admins. The SSL port is on a 2nd C class IP which is static NAT IP on our internet facing firewall. The SSL port is receiving requests from both public and private IP’s but seems to be only responding to public requests. We have proven this with Wireshark, please can anyone help?

Thanks
Simon

This is rather a networking issue than an ownCloud one, but let’s see, if these thoughts are helpful

  • Is it possible that the owncloud webserver is only listening to a specific address/subnet (have a look at the config files)
  • Are there firewall rules blocking the service?
  • To what does the ownCloud Server IP resolve? Does it help putting another IP into the hosts file?

Only when you can reach your server on the network level (there is a lot of documentation outside) you might want to add another trusted domain (or IP) to config.php, as described in the Admin Manual: https://doc.owncloud.com/server/admin_manual/maintenance/migrating.html#managing-trusted-domains

1 Like

Thank you for this, but please can you copy and paste what your config.php should look like?

Ours located in var\www\owncloud\config looks like:

<?php $CONFIG = array ( 'instanceid' => '525d667254568', 'passwPreformatted textordsalt' => '40358ae15b6a791d27e21b1ddb553318', 'datadirectory' => '/var/www/owncloud/data', 'dbtype' => 'mysql', 'version' => '5.0.22', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => '', 'dbuser' => 'owncloud', 'dbpassword' => '4b095f27e35785bd6c12128ebd3393d7', 'installed' => true, 'forcessl' => true, );

Just insert the snippet from the documentation the same way as, e.g., dbhost’ => ‘localhost’, reads.

Note that this is only a possible last step. Your server must be reachable on the network level first (you might try with curl).

(Next time you would like to remove sensitive data like passwordsalt or dbpassword)

Ok to give you some more info, our test pc on the correct network has a subnet of .105 and the owncloud sits on a subnet of .102. 105 can ping the 102 subnet, but the url or IP doesn’t open to the login page. We use a WatchGuard FW and we can see traffic getting to the Owncloud box, but then the owncloud box will not communicate back.

We’re already quite off topic here, but I’ll give it a last try:

ownCloud actually never responds, only the web server. And since this web server is listening (and responding) to the external address most likely it does not listen to the internal one or it is blocked by some firewall rules.

I’d suggest a search on curl and port scans (such as nmap), so you can debug your network settings.

  • look on the underside of your router most of the time consumer grade routers will have the default IP and password printed here
  • OR
  • open up “command prompt” on your desktop
    • click on the Windows (start) button – in the search box type in “cmd”
  • in the Command Prompt box type “ ipconfig
    • look for default gateway
    • this will most likely be your router’s internal IP address….
1 Like

This post was flagged by the community and is temporarily hidden.