Acess denied - App is not enabled Can't get into admin settinmgs anymore


I can login to my owncloud as admin but as soon as I click on “Settings” the message above is shown.
When I try to admin my users I can select the function but no user is listed.
This problem came up a few days ago but there is no significant error in my server log file (or is there a specific owncloud logfile?)

At the moment the owncloud is running but no administration is possible.
How can I enable the “Settings” app again?


i don’t think that there is a “Settings” app (this is the first time i have read from something like this). Maybe you have enabled a 3rdparty and incompatible / broken app which is causing this problem?

I would first try to update to the most recent ownCloud version 10.3.3 by following one of the options listed here (depends on the installation method, from what i have read the manual upgrade is the recommended one).

And if the problem persists then i think it could be possible to disable some of the installed apps stepwise via:

or even try to update them via:

1 Like

The error message is talking about an app.
I just want to get into the configuration using the dropdown menu on the right hand side (Configuration, Users, Logoff). And when I choose “Configuration” the mentioned error message appears.


from what i know there is no “Settings” app as explained previously (i have now looked at my own installation and can’t find one either) so you can’t enable an app which doesn’t exist. :frowning:

But from what i know some apps can “inject” additional settings into that menu (i have seen that for e.g. Collabora Online integration) and i think one which is trying this could be broken / has incompatibilities (maybe not updated, a third party app which never has really correctly defined the compatible ownCloud versions).

As no ownCloud version has been stated it could be also possible that this is due a bug in a possible used outdated ownCloud version.

I think your only chance to get the configuration menu back is to try what has been suggested previously.


I am one litte step further.
There is an app called “Settings”. (checked with occ app:list) This was disabled on my installation.
Therefore the error message came up correctly.
Using the OCC console I coud enable this app and now there is no more error message but still no configuration visible (just a white screen).
In the configuration dialog I was able to update owncloud in the past as I hate doing this throught the console.
But this not seem to be possible as no configuration page comes up.
Is there a list of required apps that must be enabled for a normal operation?
It seems that some of the apps were disabled somehow.

The owncloud page I am refering to is /index.php/settings/personal
Since I am admin I could see updates etc. on this page.


are you sure that you are using ownCloud? A occ app:list on my ownCloud installation shows the following below without any signs of an Settings app:

$ ./occ app:list
  - activity:
    - Version: 2.7.2
    - Path: /var/www/owncloud/apps/activity
  - calendar:
    - Version: 2.0.0
    - Path: /var/www/owncloud/apps-external/calendar
  - comments:
    - Version: 0.3.0
    - Path: /var/www/owncloud/apps/comments
  - contacts:
    - Version: 1.5.5
    - Path: /var/www/owncloud/apps-external/contacts
  - dav:
    - Version: 0.7.0
    - Path: /var/www/owncloud/apps/dav
  - diagnostics:
    - Version: 0.2.0
    - Path: /var/www/owncloud/apps/diagnostics
  - federatedfilesharing:
    - Version: 0.5.0
    - Path: /var/www/owncloud/apps/federatedfilesharing
  - federation:
    - Version: 0.1.0
    - Path: /var/www/owncloud/apps/federation
  - files:
    - Version: 1.6.0
    - Path: /var/www/owncloud/apps/files
  - files_mediaviewer:
    - Version: 1.0.5
    - Path: /var/www/owncloud/apps/files_mediaviewer
  - files_pdfviewer:
    - Version: 1.0.1
    - Path: /var/www/owncloud/apps/files_pdfviewer
  - files_sharing:
    - Version: 0.14.0
    - Path: /var/www/owncloud/apps/files_sharing
  - files_texteditor:
    - Version: 2.6.1
    - Path: /var/www/owncloud/apps/files_texteditor
  - files_trashbin:
    - Version: 0.9.1
    - Path: /var/www/owncloud/apps/files_trashbin
  - files_versions:
    - Version: 1.3.0
    - Path: /var/www/owncloud/apps/files_versions
  - firstrunwizard:
    - Version: 1.3.0
    - Path: /var/www/owncloud/apps/firstrunwizard
  - guests:
    - Version: 0.12.3
    - Path: /var/www/owncloud/apps/guests
  - impersonate:
    - Version: 0.6.0
    - Path: /var/www/owncloud/apps-external/impersonate
  - market:
    - Version: 0.8.0
    - Path: /var/www/owncloud/apps/market
  - music:
    - Version: 1.9.0
    - Path: /var/www/owncloud/apps-external/music
  - notes:
    - Version: 2.0.6
    - Path: /var/www/owncloud/apps-external/notes
  - notifications:
    - Version: 0.6.0
    - Path: /var/www/owncloud/apps/notifications
  - richdocuments:
    - Version: 4.1.0
    - Path: /var/www/owncloud/apps-external/richdocuments
  - systemtags:
    - Version: 0.3.0
    - Path: /var/www/owncloud/apps/systemtags
  - tasks:
    - Version: 0.9.7
    - Path: /var/www/owncloud/apps-external/tasks
  - updatenotification:
    - Version: 0.2.1
    - Path: /var/www/owncloud/apps/updatenotification
  - admin_audit:
    - Path: /var/www/owncloud/apps/admin_audit
  - announcementcenter:
    - Path: /var/www/owncloud/apps/announcementcenter
  - configreport:
    - Path: /var/www/owncloud/apps/configreport
  - customgroups:
    - Path: /var/www/owncloud/apps/customgroups
  - drawio:
    - Path: /var/www/owncloud/apps/drawio
  - encryption:
    - Path: /var/www/owncloud/apps/encryption
  - enterprise_key:
    - Path: /var/www/owncloud/apps/enterprise_key
  - external:
    - Path: /var/www/owncloud/apps/external
  - files_antivirus:
    - Path: /var/www/owncloud/apps/files_antivirus
  - files_classifier:
    - Path: /var/www/owncloud/apps/files_classifier
  - files_external:
    - Path: /var/www/owncloud/apps/files_external
  - files_external_dropbox:
    - Path: /var/www/owncloud/apps/files_external_dropbox
  - files_external_ftp:
    - Path: /var/www/owncloud/apps/files_external_ftp
  - files_ldap_home:
    - Path: /var/www/owncloud/apps/files_ldap_home
  - files_lifecycle:
    - Path: /var/www/owncloud/apps/files_lifecycle
  - files_primary_s3:
    - Path: /var/www/owncloud/apps/files_primary_s3
  - firewall:
    - Path: /var/www/owncloud/apps/firewall
  - graphapi:
    - Path: /var/www/owncloud/apps/graphapi
  - kerberos:
    - Path: /var/www/owncloud/apps/kerberos
  - metrics:
    - Path: /var/www/owncloud/apps/metrics
  - oauth2:
    - Path: /var/www/owncloud/apps/oauth2
  - openidconnect:
    - Path: /var/www/owncloud/apps/openidconnect
  - password_policy:
    - Path: /var/www/owncloud/apps/password_policy
  - provisioning_api:
    - Path: /var/www/owncloud/apps/provisioning_api
  - ransomware_protection:
    - Path: /var/www/owncloud/apps/ransomware_protection
  - sharepoint:
    - Path: /var/www/owncloud/apps/sharepoint
  - systemtags_management:
    - Path: /var/www/owncloud/apps/systemtags_management
  - templateeditor:
    - Path: /var/www/owncloud/apps/templateeditor
  - theme-enterprise:
    - Path: /var/www/owncloud/apps/theme-enterprise
  - user_external:
    - Path: /var/www/owncloud/apps/user_external
  - user_ldap:
    - Path: /var/www/owncloud/apps/user_ldap
  - user_shibboleth:
    - Path: /var/www/owncloud/apps/user_shibboleth
  - web:
    - Path: /var/www/owncloud/apps/web
  - windows_network_drive:
    - Path: /var/www/owncloud/apps/windows_network_drive
  - wopi:
    - Path: /var/www/owncloud/apps/wopi
  - workflow:
    - Path: /var/www/owncloud/apps/workflow

The problem is solved.
I could successfully migrate my owncloud to nextcloud 28 as owncloud with php 7.4 has no future to me.

Thanks anyway for your support.


i still think that you did not had ownCloud installed in the first place as there is no “Settings” app for ownCloud.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.