Activating memcache fails

memcache

#1

Steps to reproduce

  1. Enter cat < /etc/opt/rh/rh-php70/php.d/20-apcu.ini
    ; APCu php extension
    extension=apcu.so
    EOF
    as described on https://doc.owncloud.org/server/10.0/admin_manual/configuration/server/caching_configuration.html
  2. Gives back that /etc/opt/rh cannot be found. It is true, the folder does not exist in my folder structure. Installation of apcu worked withoud errors. I checked it by trying to install it again, but I get the message that nothing has been changed as everything is already up to date

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system: raspbian

Web server:

Database:

PHP version: PHP 7.0.27-0+deb9u1

ownCloud version: 10.0.6


#2

You could try this:

https://doc.owncloud.org/server/10.0/admin_manual/configuration/server/caching_configuration.html#apcu-configuration


#3

Thank you very much!

The message in the admin panel to use memcache for better performance disappeared, but there is still the message: "Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information."
How can I enable that function? The only thing I can find in the documentation is to configure apcu, as described in the links that I and dmitry provided. Only for redis, there is descirbed to add 'memcache.locking' => '\OC\Memcache\Redis', // Add this for best performance
, but I dont know what to do in debian.


#4

You may find this site of the doc very useful :slight_smile:

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/security_setup_warnings.html?highlight=warning


#5

you will to install a redis server. and then do this:

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/caching_configuration.html#configuring-transactional-file-locking