Active directory synced but usernames displayed incorrectly

hi everyone. so glad to be part of owncloud!
i have an issue in integrating with active directory. all users are synced and shown but in an awry way! by awry, i mean users ‘full names’ columns are correct but the corresponding usernames are comprised of multi character words followed by hyphens! have a look at the picture to see exactly how it looks. any ides? how can i fix this?
Capture

Hi alv,

using UUIDs for internal usernames is the default setting for ownCloud LDAP users. You may change this behavior by setting an attribute in the Expert Settings which will be used for the internal user names, see the docs:

https://doc.owncloud.com/server/10.8/admin_manual/configuration/user/user_auth_ldap.html#expert-settings

2 Likes

Let me add that the username MUST be unique across all the user backends. Using the UUID takes care of this restriction automatically for you.

If you change that setting, it’s your responsibility to ensure that all usernames will be unique. Failing to do so might cause serious problems for the affected accounts.

3 Likes

To ensure other users don’t have to type these UUIDs, just make sure you have the User Display Name Field & 2nd User Display Name Field settings in the Advanced Directory settings of the Admin User Authentication settings set to something sensible, e.g displayname, samaccountname and/or mail:

1 Like

thank you all guys. i think this is what i need; to let users enter their space without having to save uuids.

guys settings seem to be correct as if the gives a green ok, but the users page redirects to https and does not open. any ideas how to disable this? i don’t wanna enable https for now.
regards.

guys i fixed this by enabling ssl on default site of apache. it’s ok now im gonna close this topic.
thank you all.

3 Likes