"add your app" button is not available in app management section

9.1.x

#1

We'd like to add a simple app to our locally hosted instance. Trying out the app for the first time and we have having a couple of issues -

ocdev installation is problematic. It is saying version incompatible, etc...
so we put the files manually in /app folder and fix the permissions.

How do we make it so that the custom app will show up in the application? We don't intend to publish it for general use. Currently we are just experimenting with creating a new app.


#2

For development and testing I highly recommend a dedicated test instance or even a local development setup. Please see our developer manual: https://doc.owncloud.org/server/latest/user_manual/

Once you have your app within the apps folder you can enable it via the terminal:
./occ app:enable name-of-the-app


#3

Thanks so much! Yes we have it installed on a local test server.

Now I am getting myapp can't be enabled since it's not installed. I just cp a template app and changed the info.xml with my appid.

I have been watching tutorials and documentation but still not so clear about what needs done to create an app.

Any help with be appreciated.

Thanks.


#4

appid and folder name have to match.


#5

Yes that matches. Still no luck


#6

Hard to tell what the issue is. Can you put the code on github?