After upgrading to OC 9.1.1: Gallery empty, lots of errors in the log

known_app_bug
9.1.x
help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
install OC 9.1.0
add some photos
upgrade to OC 9.1.1
enter folder with photos
switch to photo view (icon in the upper right corner)

Expected behaviour
Fotos should be displayed

Actual behaviour
Page remains white, no content ist displayed.
Errors are logged:

Server configuration
Operating system: Debian Jessie
Web server: Apache 2.4.10
Database: POstgreSQL 9.3
PHP version: 5.6.24
ownCloud version (see ownCloud admin page): 9.1.1
Updated from an older ownCloud or fresh install: upgrade form older version.
ownCloud log:

{"reqId":"qnsJTBw5ZAXRknjmIi2t","remoteAddr":"IPv4","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\\/1.1 405 The resource you tried to create already exists\",\"Exception\":\"Sabre\\\\DAV\\\\Exception\\\\MethodNotAllowed\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/CorePlugin.php(588): Sabre\\\\DAV\\\\Server->createCollection('Media\\\/Fotos\\\/!Ne...', Object(Sabre\\\\DAV\\\\MkCol))\\n#1 [internal function]: Sabre\\\\DAV\\\\CorePlugin->httpMkcol(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#2 \\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/3rdparty\\\/sabre\\\/event\\\/lib\\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\\n#3 \\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(459): Sabre\\\\Event\\\\EventEmitter->emit('method:MKCOL', Array)\\n#4 \\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(248): Sabre\\\\DAV\\\\Server->invokeMethod(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#5 \\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/apps\\\/dav\\\/appinfo\\\/v1\\\/webdav.php(56): Sabre\\\\DAV\\\\Server->exec()\\n#6 \\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/remote.php(164): require_once('\\\/var\\\/www\\\/REPLACED_USERNAME...')\\n#7 {main}\",\"File\":\"\\\/var\\\/www\\\/REPLACED_USERNAME\\\/web\\\/REPLACED_VHOST\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php\",\"Line\":1121,\"User\":\"REPLACED_USERNAME\"}","level":4,"time":"2016-07-25T17:16:57+00:00","method":"MKCOL","url":"\/remote.php\/webdav\/Media\/Fotos\/!Neue_Photos_unsortiert\/2016_07_24","user":"REPLACED_USERNAME"}
{"reqId":"VYPbH2Q\/XW122K1VIRX\/","remoteAddr":"IPv4","app":"gallery","message":"Exception: The owner has placed a restriction or the storage location is unavailable","level":3,"time":"2016-07-26T08:30:38+00:00","method":"GET","url":"\/index.php\/apps\/gallery\/files\/list?location=160703_Besuch_MüllerMaier&mediatypes=image%2Fpng%3Bimage%2Fjpeg%3Bimage%2Fgif%3Bimage%2Fx-xbitmap%3Bimage%2Fbmp&features=&etag","user":"REPLACED_USERNAME"}
{"reqId":"rZEOme0SZZW1ND6KQ8J5","remoteAddr":"IPv4","app":"PHP","message":"Argument 8 passed to OC\\Core\\Controller\\AvatarController::__construct() must implement interface OCP\\Files\\Folder, null given, called in \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/core\/Application.php on line 96 and defined at \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/core\/Controller\/AvatarController.php#88","level":3,"time":"2016-07-26T19:17:11+00:00","method":"GET","url":"\/index.php\/avatar\/REPLACED\/32","user":"--"}
{"reqId":"v3iBJuE8h6x8BWyf5OWw","remoteAddr":"IPv6","app":"PHP","message":"Argument 2 passed to OCA\\Files\\Service\\TagService::__construct() must be an instance of OCP\\ITags, null given, called in \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/apps\/files\/lib\/AppInfo\/Application.php on line 87 and defined at \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/apps\/files\/lib\/Service\/TagService.php#52","level":3,"time":"2016-07-27T19:10:21+00:00","method":"POST","url":"\/index.php\/apps\/files\/api\/v1\/sorting","user":"--"}
{"reqId":"v3iBJuE8h6x8BWyf5OWw","remoteAddr":"IPv6","app":"PHP","message":"Argument 3 passed to OCA\\Files\\Service\\TagService::__construct() must implement interface OCP\\Files\\Folder, null given, called in \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/apps\/files\/lib\/AppInfo\/Application.php on line 87 and defined at \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/apps\/files\/lib\/Service\/TagService.php#54","level":3,"time":"2016-07-27T19:10:21+00:00","method":"POST","url":"\/index.php\/apps\/files\/api\/v1\/sorting","user":"--"}
{"reqId":"G4SwN9WzrquaMVgJRmY3","remoteAddr":"IPv6","app":"PHP","message":"Argument 2 passed to OCA\\Files\\Service\\TagService::__construct() must be an instance of OCP\\ITags, null given, called in \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/apps\/files\/lib\/AppInfo\/Application.php on line 87 and defined at \/var\/www\/REPLACED_USERNAME\/web\/REPLACED_VHOST\/apps\/files\/lib\/Service\/TagService.php#52","level":3,"time":"2016-07-27T19:10:24+00:00","method":"POST","url":"\/index.php\/apps\/files\/api\/v1\/sorting","user":"--"}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
None

Integrity status for oC9+

No errors have been found.

#2

Please post the output of:

./occ app:list (see doc.owncloud.org for more info about occ)


#3

Hi,
The output is:
Enabled:
- activity: 2.3.2
- comments: 0.3.0
- dav: 0.2.6
- federatedfilesharing: 0.3.0
- federation: 0.1.0
- files: 1.5.1
- files_external: 0.6.0
- files_mv: 0.8.2
- files_pdfviewer: 0.8.1
- files_sharing: 0.10.0
- files_texteditor: 2.1
- files_trashbin: 0.9.0
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- firstrunwizard: 1.1
- gallery: 15.0.0
- notifications: 0.3.0
- systemtags: 0.3.0
- templateeditor: 0.1
- updatenotification: 0.2.1
Disabled:
- encryption
- external
- files_antivirus
- provisioning_api
- user_external
- user_ldap


#4

When having such issues please always disable 3rdparty apps before reporting any issues. In your case the issue is most likely caused by:

That 3rdparty app is known to be broken since ages. Because of this it is also breaking the gallery as seen e.g. here:


#5

Indeed, it is the same error as I reported in 9.1.0

However, a patch was submitted by oparoz in the mentioned issue (https://github.com/owncloud/gallery/issues/699) I assumed it was integrated already.

To be honest, I'm a bit confused:
files_mv is delivered out of the box - then it should work. If a patch is provided by someone fixing isues (see link above), it should be integrated upstream. If OC devs decide to abandon files_mv then they should remove it.

Don't deliver apps in a dysfunctional state.

It is the second time I stumble of the issue. If I deactivate files_mv, what is the recommended/OC-ish way to move files or folders through multiple folder hierachies to now locations. Currently I'm only aware of files_mv to achieve that.

Thanks for your help,
Torben


#6

files_mv is a 3rdparty app developed and provided by a 3rd party app developer. It is NOT provided "out of the box" or delivered by/with ownCloud.

The fix by @oparoz was submitted to https://github.com/eotryx/oc_files_mv/pull/29 but it seems the app developer of that app doesn't care.


#7

Additionally to this the app is only shown when "experimental apps" are enabled where you get a big red warning in the app list:

Experimental applications ahead

Experimental apps are not checked for security issues, new or known to be unstable and under heavy development. Installing them can cause data loss or security breaches.

The big red "Experimental" button besides the "Files move" app is also showing:

This app is not checked for security issues and is new or known to be unstable. Install at your own risk.


#8

+1 for you: It is marked as experimental.

ah, is the "apps" page a online repository? Then you may be right that it is not shipped with OC. I only went to the apps page and activated files_mv.

Ok, given files_mv is crap. How do I move files/folders in the webinterface?


#9

Ah, now i understand your concerns / post above. Yes, everything in the categories like "Tools" is pulled from https://apps.owncloud.com/.

Moving files and folders is natively supported in ownCloud by "drag'n'drop" like described here:

https://doc.owncloud.org/server/9.1/user_manual/files/access_webgui.html#moving-files


#10

Hm, this means I can only drag foles/folders only in parental folders, but not down into another parallel folder

A move from folder1/subfolder1/moveme into folder1/subfolder2/moveme would require a two-step operation:
step 1: Move upwards to folder1
step2: Move downwards into subfolder2.

Are there plans to show the folder hierarchy in a left pane as it is done for example in MS explorer? This would ease drag'n'drop...


#11

Hi,

you can check the issue tracker at https://github.com/owncloud/core/issues if something like this is planned. I don't have any insights into the development process.


#12

The same happens to me, but i don't have the files_mv enabled.
I'm running PHP-FPM with apcu cache enabled, so i think there's should be the problem.
Any clue?

Thanks in advance