Allowed domain seems not working on owncloud using lighttpd


#1

i put my ip addr in /var/www/html/owncloud/config/config.php

‘trusted_domains’ =>
array (
0 => ‘192.168.1.9’,
1 => ‘192.168.1.20’,
2 => ‘xxx.xx.xx.xxx’, "this is ip of my vpn or external ip when at home

)

but when i try to connect is says

You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the “trusted_domains” setting in config/config.php. An example configuration is provided in config/config.sample.php or at the documentation.

running raspbian strech on a pi 3+


#3

wtf is this are you a prankster or just a funnu punk


#4

Hey,

could it be possible that you’re trying to add the IPs/URLs of your clients and not the one of your server to the trusted_domains setting?

Maybe the documentation here helps you to understand what to put into the setting:

https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#managing-trusted-domains


#5

indeed thanks.

so when i added server it works but i tried from my mac using office vpn and it timed out .
will read this documentation and update later


#6

Hey,

if a connection is timing out i would expect some networking issues unrelated to ownCloud.


#8

Hey,

this was directed to a post of a spam bot which seems to be deleted now.


#9

Ah, I see. Thanks.

If you don’t feed the trolls, you’ll never have to delete anything. :wink:


#10

hi tom thanks for your help. i appreciate
so from the outside i am timing out .

i have open port 80 on my router which is the port lighttpd is running.
from inside i can use the url but not from the outside any thing i can show to troubleshoot


#11

Hey,

i think you’re probably not the only one having networking issues while running software like ownCloud.

Personally i would search around here at the forums or having a look for some network related tutorials and troubleshooting guides to see if you can get your network setup to work as expected.


#12

anything to consider concerning OC if i switch to apache wondering if there some setting in lighttp im not aware off


#13

Meanwhile there are 3 topics in this thread, trusted domains, network timeout and server change. Is the initial problem solved?


#14

not sure on the intentions of your participation …

yes trusted domain is solved , but topic has evolved. are you suggesting i start a new topic for network timeout


#15

this is solved now . even-though i had port forwarding correct my isp had closed port 80 .
After they reopened it i am able to connect from the outside

thanks


#16

Well, my intention is to help, share my experience with others. But its getting complicated, if a thread is flooded with multiple unrelated topics.

To answer your question: Yes, I suggest opening a new thread for any unrelated topic.