Am I setting up ownCloud correctly?

9.1.x

#1

So here's a little background, I've submitted two questions about this before. Here's the first and second.

Basically my ownCloud instance works as expected until I try and upload large files. You can look at the two other posts if you need to, but I tried every solution mentioned in FAQ posts recommended, I wiped the hard drive and started over, I've even tried owncloud instances on VMs and tinkered around with them with no success.

I've decided to post my instructions for installing to see if maybe I'm missing something. These instructions are executed on a clean install of Ubuntu 16.04 Server.

sudo curl https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/Release.key | sudo apt-key add -
echo 'deb https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/ /' | sudo tee /etc/apt/sources.list.d/owncloud.list
sudo apt-get update
sudo apt-get install owncloud
sudo systemctl reload apache2
sudo apt-get install mysql-server
mysql -u root -p
CREATE DATABASE owncloud;
GRANT ALL ON owncloud.* to 'owncloud'@'localhost' IDENTIFIED BY 'PUT A PASSWORD';
FLUSH PRIVILEGES;
exit

I literally copy and paste those commands into my ssh window when setup owncloud. I then go to setup page in a browser, choose mySQL for the database and create credentials for an admin account. I then go to admin settings and change the max upload limit to 10 GB (I've tried different upload limits, no change).

So the ultimate question is, am I missing a step? Am I missing something very important in the setup process that would cause the problems I encountered in the first two posts where uploads of larger files simply will not work?

My test files for large files are generally linux iso files. Raspbian, Ubuntu, Ubuntu server, etc. They start uploading for a few seconds and then I get unable to write or something along those lines with a "expected filesize 10000000 got 8255842" error in the logs.

Thanks in advance for any help. I've been trying to figure this out for months now.