Android app doesn't work correctly

On a previous topic, I explained how your Android upgrade completely broke it. Let me explain to you WHY it is critical that we have the option to make the files available clearly to other app w/o going through the OwnCloud app interface…

1> the feature to open with another app from inside OwnCloud DOES NOT WORK! I gave up on it, but didn’t care too much because I could open the files via my apps, such as Markor, directly without going through the OwnCloud app.

2> The “Set as available offline” features is not reliable or does not work. I thought for sure I’d be able to access my documents when offline, which I often am. Nope. It kept trying to talk to the server even though I sync’d the files LONG AGO. Why couldn’t it open offline? No idea. But, once again, it was a minor inconvenience as I was able to find it locally on my file system and open direct from the app that needed it.

Now, with your new upgrade forcefully moving my files to a “secure location”, I can no longer do that. It means I can no longer find my files, open with another app, or view or edit them offline. This was the whole purpose of OwnCloud… to make my files available on my devices when I was offline via my apps and then sync changes later.
Don’t have to worry about sync’ing since I can’t make changes to files I can’t find or open!

About the Scoped Storage, i answered you in other post.

About the “Open With”, could you give more details? or open a new issue in our open GitHub repository? i can use the “open with” correctly. Let’s try to find out what’s going on in your side

About the av. offline, i do not understand your problem. Av. offline feature works by fetching the last version of a file when the container folder is browsed, or all the containing files if the folder is av. offline. Could you clarify?

Thanks for reporting.

@jesmrec

  1. Create a markdown (*.md) file on desktop.
  2. Install Markor via f-droid on mobile.
  3. Try to open your markdown in Markor via OwnCloud Android using either Open with or Send to.

Let me know if you can get it to work. Before this update, I simply opened the file itself with Markor which was accessible where I wanted it. If Google is forcing files to no longer be accessible to users, GOOGLE IS WRONG. I chose OwnCloud because GOOGLE IS OFTEN WRONG and want to be free of Google.

Can you please fork and build the old OwnCloud app for F-droid users who don’t want Google to dictate how we use our devices?

As for offline, I couldn’t open a file at all because it kept trying to access the server and just hung. Perhaps offline worked in that it had a local copy. I learned how to open the file directly from the file system, so if that is what offline did, then I was happy. But, obviously, that’s no longer an option with this update. So, if Owncloud hangs trying to open a file cuz it can’t talk to the server, then I’m dead in the water. I can’t take that risk so now have to be sure I have w/e I need w/o OwnCloud, leaving OwnCloud useless today on mobile.

What good is it to have it in Play store if it is useless?

If OwnCloud will no longer do simple file sync’ing, can you please recommend a tool we can use to sync our file systems between devices and desktops?

Very interesting (and reasonable) idea. But please don’t expect that this will be done anytime.

ownCloud Android app is (and was) available in Fdroid. Just search for it there and you can get older versions.

In release owncloud android Android Client 2.20.0 (2022-02-16) i can see a change:

Enhancement - “Open with” action now allows editing: #3475

But still usign “open with” with "markor shows an error.
I would like to edit markdown-files syncronising with my owncloud on android. Is there a special editor in playstore i have to use for this to work?

@Hiro no, the idea of such new feature is:

  1. Download your file in the oC app
  2. Select “open with” and choose an app (Markor in your case)
  3. Edit your file, and save
  4. Go back to oC
  5. By browsing in the containing folder, the file should sync to the server

Could you detail the steps you do? which error do you receive?

Hi there,

I would like to double down on the reason this thread was started, as I have a probably interesting use case here :slight_smile:

I can’t Sync my Obsidian Vault across my different devices because of the lack of access to the files on Android (which I initially thought was supported from quick diagonal reading online and was my main purpose).

I’ve been combining my old BTSync-now-ResilioSh*t file repo with my SyncThing setup (for Obsidian only - but not av on iOS) into my new ownCloud server on my Ubuntu NAS, hoping it would just come together just fine and be usable by everyone at home from Android, iOS, Windows & Mac… but can’t find my Obsidian folders on my Android phone - haven’t tried yet with my wife’s iPhone.

I can see OneDrive and Google Drive into the “My Files” app on my S10 so I thought OwnCLoud could be there… but I can’t see them in Obsidian’s “Vault” folder picker anyway. (I can only see my old MEGA folder there, which I really should regroup in my shiny new OwnCloud soon :slight_smile: #springcleaning).

Could making a/all folder(s) available “on drive” be a folder/account setting?
I initially thought the “Lock access from document provider” would be doing something like this.

Any other idea I could benefit from?

Cheers

PS: Seems like NextCloud may (still?) support it…

Similar here:

  1. Choose text file in oc app
  2. Download file
  3. Open with (DroidVim in this case)
  4. Modify/save file
  5. Exit DroidVim
  6. Back in oc app, but nothing happens

Reopening the file again shows the original, not modified version of the file.

Making the file available offline or disabling the lock access from document provider in the settings doesn’t help.

Any hint?

@Danstroem i’ve checked the DroidVim, and that app does not allow to read the internal storage to accomplish the November’21 new Google policies. I got the following warning:

Screenshot 2022-02-24 at 13.05.59

I really understand all your complains about the new location. It is annoying when your use case is broken. But, every app that is distributed via Google market must adopt the Google rules. Nowadays, there are many many many apps that don’t adopt them, when three months have passed after the changes are out. Every app handling files and published in Google Play should implement document provider (SAF framework) to interact with other apps’ files. Getting and pushing files directly to the file system seems to be a deprecated feature.

Thank you @jesmrec for checking this. Looks like we are all in the same (Google) boat :neutral_face:

1 Like

@jesmrec I’m beginning to understand, that Google forces you to a certain way of handling files. But I don’t understand, what other way, if not the file system, there should be to access files from other apps. If one app downloads a file (i.e. syncs with ownCloud) there must be a way that other apps can access that file, or the entire system of storing files is left useless ???
If you don’t call it file system but “document provider” then there still must be a way for a file manager (like in my case TotalCommander) to access these documents or files … what’s the difference???
Sorry, didn’t want to flame. I appreciate the work, you put into this and understand the pressure, Google puts on you, I just don’t undestand why they have to reinvent the wheel every couple of years.