Android client log in using webbrowser and stays in browser issue

Hello

Recently i downloaded and installed ownCloud Android client.
I wanted to log in.

Application prompted me for server address and then once i have entered the server address a small status message under the input field was telling “connecting to OAUth2 server” and suddenly app is asking to open a new browser window.

Once browser window is opened - login page to my server is loaded.
After i log in using this login page, application remains in the browser view and i cannot get ahold of the native UI.

I am running ownCloud server version: 10.9.1
android owncloud Client is in version: 2.21

Could somebody please help me what is the problem, what am i doing wrong or is there a known issue in the android client?

Thank you!

Did you get any feedback from the browser after entering your credentials inside?

Yes i did.
It logged me in and loaded user homepage with files - inside the browser.
When i tried to open another instance of the ownCloud client, it showed me that i am not logged in and i had to repeat the same process with same result.

So, the flow stays at the browser and there is no callback to the app. Which device and Android version are you using? which browser in device? this sounds like a branding problem, but, if you retrieved the app from Google Play, that hypothesis is not posible.

I am using Android 10 with kernel 4.9.190
Its a Gigaset GS290 device.
I have tried multiple browsers Chrome included.
Its exactly as you described - there is no callback. It stays in the browser and thats it.

At this point i will mention that i am using cloudflare proxy.
Could it be that some http header manipulation is preventing the app callback?

So, to save time, does it work without proxy?

1 Like

Could you check with demo.owncloud.com?? it also uses browser authentication.

1 Like

Yes i was able to log into the demo owncloud instance and i see native client ui.
Ok that means the client UI works.
That means i have some configuration wrong on backend or on cloudflare.
Could it be that i am terminating client TLS on cloudflare and there is a separate TLS initiated between cloudflare and backend?

That seems a reasonable option.