Android client no longer uploading images


#1

Happy new year everybody!

This used to work just fine until I updated my Android ownCloud client a few days ago.
Now I run the owncloud Android client v 2.9.3, connecting to an owncloud server version 10.0.10.4 on a hosted domain.

The client is working fine for normal file sync (I had to re-enter my password), but when I take a picture, I no longer see the status bar message that owncloud is uploading the image (and no image is indeed uploaded). I did re-enable “Picture uploads” in the client settings. I also set the “Picture upload path” to “/InstantUpload” (which was the old location). “Upload pictures via wifi only” is unchecked. I also set the “Camera folder” to /storage/sdcard1/DCIM/Camera, which is where my camera app stores any images (as verified by taking a picture and then looking at “Details” for the picture (it says: Path: /storage/sdcard1/DCIM/Camera/IMG_20190101_133995.jpg).

So for some reason, the client seems not to detect the new picture and never initiate the upload/sync. I tried rebooting, and also checked the app privileges - no improvement.

Any suggestions?
Thanks!

PS: Additional detail: When I view the picture and then select Share > ownCloud and select my account and the InstantUpload folder, everything works as expected.


#2

Happy new year @mart314, after reading your comment but when I take a picture, I no longer see the status bar message that owncloud is uploading the image it seems you are waiting for an instant upload but the Camera uploads feature will take 15 minutes at most to detect the new picture and upload it.

Can you confirm that after waiting that period of time the pictures are not uploaded? Thanks!


#3

Unfortunately, waiting for 15 minutes (or 7 hours) did not make any difference. No upload, no “failed” entry in the Uploads section of the app.


#4

Any idea what’s causing this or how to drill down further to find out?


#5

Hey,

maybe it is related to the following issue below? If its not the same then i think you could consider to open an new issue at the same issue tracker to get some attraction by some android developers.


#6

No, it’s not the same issue. For me, the sync is already failing for normal pictures.
I could open an issue but I have no idea how to provide any log data. Anyone?

Ah, one more thing: I did change the SD card a few weeks ago because the old one was filling up.
I did so by copying over all files, which seemed to work fine.
Could this be causing owncloud to fail to detect any new image?


#7

Hey,

maybe the android devs can tell you that after opening a new issue?