Android error connecting to server

help

#1

Please help us by providing the following info.

Steps to reproduce
1. connect via Android Owncloud client
2. typ the connection: https://.../owncloud
3. Message: testing
4. Error message: Error connecting to server

Other steps undertaken:
- connecting via mobile browser: works OK
- connecting to test owncloud: works OK
- connecting not via WIFI, but via mobile subscription: works OK
- connection via windows desktop client: works OK
- connecting to webdav via browser: works OK

I've checked my own router settings: same behaviour even when no restrictions are on

Expected behaviour
A secure connection should be established. And next step is to login.

Actual behaviour
Error message: Error connecting to server

Mobile client configuration
Client OS (iOS, Android, ...): Android
Client version: 6.0.1

Server configuration
Operating system: Ubuntu 16.04
Web server: Apache2.4.1
Database: SQLLite
PHP version: 7.0
ownCloud version (see ownCloud admin page): 9.1
Updated from an older ownCloud or fresh install: fresh install
ownCloud log (data/owncloud.log): no entry in the log, nor in apache error.log or access.log

Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): none


#3

Thanks for taking the time to reply. But what do you mean?


#4

Hi, @suzzper.

So, if I understood correctly, the Android app works fine when you access from the Internet, but not in your local network?

The rest of the tests you did (mobile browser, desktop client): were they via local WiFi ?

Is this something new, or has always failed for you?


#5

Hi Davivel,

Thank you for your reply.
Your assumptions are correct. It's all working on my local network except the android client. In the meanwhile I've also tried a different app on my android. But that gave the same error. Other apps like Ownnote and Easy DAV for Owncloud are working fine.
It used to work. But I changed first from Apache to Nginx, unsuccessfully. And changed my Webserver back to Apache. The difference now is that I'm using a Letsencrypt certificate. Before I used a self signed certificate.
Of course I could try to reinstall everything again but I would like to find out the reason why it's not working.
Any tip or advice is welcome here :grinning:.
Kind regards,

Suz


#6

@suzzper, might be related with the change of certificate, though I would expect a different behaviour from the app in that case.

Did you try to clean the app storage in your device and log-in then? In device Settings > Apps > ownCloud > Storage > Manage Space button > Clear Data button.


#7

Hi Davivel,
Yes I've cleaned the storage and tried to login again -> still same error.
I've checked the certificate on my device, via Firefox and Chrome. Both inform me that the certificate is valid.

Kind regards,

Suz


#8

What is the minor version of your OC server? Is it 9.1.0, 9.1.5, in the middle?


#9

server version: 9.1.5


#10

Hi @suzzper. Sorry for coming back so late.

Could you try ownCloud Android app 2.4.0, released last Monday?

Thx.


#12

Hello,

I have exactly the same problem with ownCloud 10.0.6.
I tried with different Android clients :

  • ownCloud : error message "The connection took too much time".
  • Cirrus : error during download of a file "An error occured during the connection to the server"
  • Solid Explorer : it works but very very slowly.

If I disconnect the wifi and connect to the Internet with Mobile network, it works great.

Any idea?