Any debian experts?


#1

Just logged into my server to do a routine upgrade. I'm running OC 9.1.0-1.1 on Debian 8 with php5, and I issued:

aptitude dist-upgrade

... and I got:

The following packages will be REMOVED:
libgd3{u}
The following packages will be upgraded:
php-pear php5 php5-cgi php5-cli php5-common{b} php5-curl php5-gd{b} php5-imap php5-intl{b} php5-ldap php5-mcrypt php5-mysql php5-pgsql php5-sqlite php5-tidy
The following packages are RECOMMENDED but will NOT be installed:
php5-readline
15 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 283 kB/10.6 MB of archives. After unpacking 2,663 kB will be used.
The following packages have unmet dependencies:
php5-common : Conflicts: php5-json but 1.3.6-1 is installed.
php5-gd : Depends: libjpeg8 (>= 8c) which is a virtual package.
Depends: libt1-5 (>= 5.1.0) but it is not installable.
php5-intl : Depends: libicu48 (>= 4.8-1) but it is not installable.
The following actions will resolve these dependencies:

 Remove the following packages:

1) owncloud
2) owncloud-deps-php5
3) php5-gd
4) php5-intl
5) php5-json


Clearly, I don't want to remove owncloud or any of the dependencies, and fixing any of the conflicts seems to create other conflicts.

Any idea how to resolve these conflicts so I can at least keep my server running?


#2

Hi,

seems you have some mixed packages or repositories. The php5-intl package which depends on libicu48 for example is from Debian 7:

https://packages.debian.org/wheezy/php5-intl

where the Debian 8 version depends on the correct libicu52:

https://packages.debian.org/jessie/php5-intl

The same issue can be seen with:

https://packages.debian.org/wheezy/php5-gd

vs.

https://packages.debian.org/jessie/php5-gd

As this is clearly not an issue concerning ownCloud i'm closing here. Please try to get some help from Debian experts at e.g. http://forums.debian.net/


#3