APCu not available for local and distributed cache

9.1.x
help

#1

Hello, I got trouble with APCu. It says Memcache \OC\Memcache\APCu not available for distribute/local cache, but APCu is running (Version 4.0.10)

Expected behaviour
normaly this should work

Actual behaviour
Memcache \OC\Memcache\APCu not available for local cache
Memcache \OC\Memcache\APCu not available for distributed cache

Server configuration
Operating system: CentOS 7
Web server: Apache 2.4.6
Database: MariaDB 10.1.16
PHP version: 5.5.21
ownCloud version (see ownCloud admin page): 9.1.0
Updated from an older ownCloud or fresh install: no
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

{"reqId":"XX","remoteAddr":"","app":"no app in context","message":"Invalidating tokens older than 2016-07-28T01:45:02+00:00","level":1,"time":"2016-07-28T08:45:02+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for local cache","level":1,"time":"2016-07-28T09:00:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for distributed cache","level":1,"time":"2016-07-28T09:00:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"no app in context","message":"Invalidating tokens older than 2016-07-28T02:00:01+00:00","level":1,"time":"2016-07-28T09:00:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for local cache","level":1,"time":"2016-07-28T09:15:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for distributed cache","level":1,"time":"2016-07-28T09:15:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"no app in context","message":"Invalidating tokens older than 2016-07-28T02:15:01+00:00","level":1,"time":"2016-07-28T09:15:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for local cache","level":1,"time":"2016-07-28T09:30:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for distributed cache","level":1,"time":"2016-07-28T09:30:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"no app in context","message":"Invalidating tokens older than 2016-07-28T02:30:02+00:00","level":1,"time":"2016-07-28T09:30:02+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for local cache","level":1,"time":"2016-07-28T09:45:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"cli","message":"Memcache \\OC\\Memcache\\APCu not available for distributed cache","level":1,"time":"2016-07-28T09:45:01+02:00","method":"--","url":"--","user":"--"}
{"reqId":"XX","remoteAddr":"","app":"no app in context","message":"Invalidating tokens older than 2016-07-28T02:45:01+00:00","level":1,"time":"2016-07-28T09:45:01+02:00","method":"--","url":"--","user":"--"}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

  • SELinux enforced

Integrity status for oC9+

No errors have been found.

#2

Hi,

you need to configure the following php.ini config options to prevent that these messages appears:


#3

Okay, I'll try this. Thanks!

By the way, can you tell me something about this line?

{"reqId":"XX","remoteAddr":"","app":"no app in context","message":"Invalidating tokens older than 2016-07-28T02:00:01+00:00","level":1,"time":"2016-07-28T09:00:01+02:00","method":"--","url":"--","user":"--"}

#4

Please try to not mix different issues / questions in one thread for the reasons described here:

https://central.owncloud.org/t/why-should-i-create-a-new-thread-for-each-question-problem/1123

#5

Errors are still there ... :confused:


#6

Then you probably have choosen the wrong php.ini. There are two, one for your webserver and one for the command line / cli.


#7

Thanks, this worked fine :slight_smile: