Appliance: 503 error after upgrading to OS X 15.5 (Catalina)

After upgrading our Mac Mini (2018) OS X from Mojave to Catalina, We are unable to access owncloud from client or from the browser. We are able to login to the Univention portal. We do have access to the Virtual Box Appliance’s command line.

Steps to reproduce

Go to (address)/owncloud
or
Check owncloud client app’s settings

Expected behaviour

Login window to Owncloud appears
or
List of synced folders show in the settings window

Actual behaviour

Service Unavailable page shows on browser

No connection message in the settings window

Server configuration

Operating system: OSX Catalina (15.5)

Web server:
Virtual box appliance setup (Apache)

Database:
Virtual box appliance setup (MySQL)

PHP version:
7.0.33

ownCloud version: (see ownCloud admin page)
10.2.1-1

Updated from an older ownCloud or fresh install:
From older ownCloud

Where did you install ownCloud from:
Virtual box Appliance from:

Signing status (ownCloud 9.0 and above):
Unable to login to Web UI

The content of config/config.php:
Unable to retrieve by the suggestions below, occ command not found

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:
Let’s Encrypt

Are you using external storage, if yes which one: local/smb/sftp/…
No
Are you using encryption: yes/no
yes

Are you using an external user-backend, if yes which one:
No

Client configuration

Browser:
Firefox, Chrome, Safari, Internet explorer

Operating system:
Windows 10 pro x64, OSX Catalina (15.5)

Logs

Web server error log

None

ownCloud log (data/owncloud.log)

File too large, here is the most recent entry:

{“reqId”:“TyNGAD6MhC4vbu69uQqA”,“level”:3,“time”:“2020-06-23T05:38:34+00:00”,“remoteAddr”:"",“user”:"–",“app”:“no app in context”,“method”:"–",“url”:"–",“message”:“Caused by: {“Exception”:“PDOException”,“Message”:“SQLSTATE[HY000]: General error: 2006 MySQL server has gone away”,“Code”:“HY000”,“Trace”:”#0 \/var\/www\/owncloud\/lib\/composer\/doctrine\/dbal\/lib\/Doctrine\/DBAL\/Driver\/PDOStatement.php(105): PDOStatement->execute(Array)\n#1 \/var\/www\/owncloud\/lib\/composer\/doctrine\/dbal\/lib\/Doctrine\/DBAL\/Connection.php(849): Doctrine\\DBAL\\Driver\\PDOStatement->execute(Array)\n#2 \/var\/www\/owncloud\/lib\/private\/DB\/Connection.php(187): Doctrine\\DBAL\\Connection->executeQuery(‘SELECT appid,…’, Array, Array, NULL)\n#3 \/var\/www\/owncloud\/lib\/private\/AllConfig.php(389): OC\\DB\\Connection->executeQuery(‘SELECT appid,…’, Array)\n#4 \/var\/www\/owncloud\/lib\/private\/AllConfig.php(271): OC\\AllConfig->getUserValues(’’)\n#5 \/var\/www\/owncloud\/lib\/private\/legacy\/util.php(233): OC\\AllConfig->getUserValue(’’, ‘owncloud’, ‘isGuest’, false)\n#6 \/var\/www\/owncloud\/lib\/private\/Files\/Filesystem.php(352): OC_Util::setupFS()\n#7 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(1176): OC\\Files\\Filesystem::resolvePath(’\/files_encrypti…’)\n#8 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(540): OC\\Files\\View->basicOperation(‘file_exists’, ‘\/files_encrypti…’)\n#9 \/var\/www\/owncloud\/lib\/private\/Encryption\/Keys\/Storage.php(234): OC\\Files\\View->file_exists(’\/files_encrypti…’)\n#10 \/var\/www\/owncloud\/lib\/private\/Encryption\/Keys\/Storage.php(112): OC\\Encryption\\Keys\\Storage->getKey(’\/files_encrypti…’)\n#11 \/var\/www\/owncloud\/apps\/encryption\/lib\/KeyManager.php(553): OC\\Encryption\\Keys\\Storage->getSystemUserKey(‘pubShare_46e656…’, ‘OC_DEFAULT_MODU…’)\n#12 \/var\/www\/owncloud\/apps\/encryption\/lib\/KeyManager.php(144): OCA\\Encryption\\KeyManager->getPublicShareKey()\n#13 \/var\/www\/owncloud\/apps\/encryption\/lib\/Users\/Setup.php(83): OCA\\Encryption\\KeyManager->validateShareKey()\n#14 \/var\/www\/owncloud\/apps\/encryption\/lib\/AppInfo\/Application.php(71): OCA\\Encryption\\Users\\Setup->setupSystem()\n#15 \/var\/www\/owncloud\/apps\/encryption\/appinfo\/app.php(30): OCA\\Encryption\\AppInfo\\Application->__construct(Array, true)\n#16 \/var\/www\/owncloud\/lib\/private\/legacy\/app.php(239): require_once(’\/var\/www\/ownclo…’)\n#17 \/var\/www\/owncloud\/lib\/private\/legacy\/app.php(190): OC_App::requireAppFile(‘encryption’)\n#18 \/var\/www\/owncloud\/lib\/private\/legacy\/app.php(124): OC_App::loadApp(‘encryption’)\n#19 \/var\/www\/owncloud\/lib\/private\/Console\/Application.php(99): OC_App::loadApps()\n#20 \/var\/www\/owncloud\/console.php(105): OC\\Console\\Application->loadCommands(Object(Symfony\\Component\\Console\\Input\\ArgvInput), Object(Symfony\\Component\\Console\\Output\\ConsoleOutput))\n#21 \/var\/www\/owncloud\/occ(11): require_once(’\/var\/www\/ownclo…’)\n#22 {main}",“File”:"\/var\/www\/owncloud\/lib\/composer\/doctrine\/dbal\/lib\/Doctrine\/DBAL\/Driver\/PDOStatement.php",“Line”:105}"}

Browser log

None

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

Please let us know if you need additional information

Check the available disk space inside the appliance, and why the mysql service didn’t start.

You will need to log in to the appliance console and make sure all services come up correctly. That the Univention portal isn’t working is a sign that there is a general problem with your appliance.

Perhaps you might also want to consult the Univention forums…

1 Like

Thank you very much for your response.

  1. The Univention portal is working

  2. According to the appliance console, the available space is 8.8GB

  3. When investigating why MySQL did not start, what should I look for first?

Can you post the output of df -h and the logs from the docker container docker-logs owncloud_owncloud_1?

Look for something like this:

Creating volume folders...
Creating hook folders...
[11.shibd.sh] check if ucs shibd service exists...
 [ ? ]  hwclock.sh
[11.shibd.sh] no shibd found...
Waiting for MySQL...
services are ready!
Waiting for Redis...
services are ready!
Writing config file...
Fixing base perms...
1 Like

Hey,

could it be possible that this is related to the following issue in UCS?

Finally, we have hired a freelancer to take a look at our configuration and solved the problem.

Our hire discovered the issue was due to the outdated media player in the appliance. After the media player was disabled, our system came back running.

Hopefully this will help others with similar problems. Thank you all for your help.

3 Likes