Attempt to upgrade from 9.1.0.15 to 10.0.10


#1

I followed the directions at https://doc.owncloud.org/server/10.0/admin_manual/maintenance/manual_upgrade.html for manually upgrading the server
I enabled maintenance mode
I stopped the webserver
I renamed my directory with a -old and unpacked the tar into the /var/www/owncloud directory
I copied over my config and data
I tried to disable the apps and got an error saying my php install (5.5.9) was too old, so I upgraded to php 5.6
now i get all kinds of errors when trying to run any php occ command
I tried changing the owner of the files in /var/www/owncloud to my www-data user with no luck either

example output

sudo -u www-data php occ app:disable activity


#2

ok so i fixed my own problem…

along with the base php5.6 package i needed to install the following php5.6 packages

zip
dom
XMLwriter
XMLreader
intl
libxml
mb
GD
cURL

after installing those I was able to run the occ commands to finish the upgrade successfully

then after restarting the webserver i got an error at the index page saying i was still using php5.5.9

I needed to disable php5 in apache and enable 5.6, then restart apache, all seems to be good now