Autocomplete off on password field


#1

It appears that you have a reversion of this issue:

https://owncloud.org/security/advisory/?id=oC-SA-2013-023

I am running 9.0.2 and my login form's password field has autocomplete turned on.


#2

Starting with Firefox 30 Mozilla is now ignoring this parameter according to its changelog:

http://www.mozilla.org/en-US/firefox/30.0/releasenotes/

More infos about the reasons are available in this bugreport: https://bugzilla.mozilla.org/show_bug.cgi?id=956906

The same goes for Chrome 34+: http://www.theregister.co.uk/2014/04/09/chrome_makes_new_password_grab_in_version_34/

Safari also ships an option to ignore the autocomplete=off parameter but currently don't have enabled this option as a default.

Disabling autocomplete makes no real sense as it won't be used anyway.