Automatic Resize of Quotas?


#1

Hey everybody,
we are using Owncloud 9.0 Server (community edition).
We use Active Directory synchronization.
Today, every night all quotas seems to be resized to 953.7 MB.
But why? Mostly people got unlimted as quota and we can update it manually every day.
In documentation I found no hint for that? Does it depend on free space and an automatic calculation?
How could I stop it? That is terrible because many users got errors on morning (out of space) and there are 15 GB of free space in server which could be enhanced in case its needed.
Or is it an error?

Thank you.

Best regards

Maik Wienströer


#2

Are you running apps that do use the quota in anyway and are not part of the usual apps (other than calendar, contacts)? Your cronjob ran for the last time very recently (check on admin page). Anything in the logs? Code-integrity check?


#3

Hey,
thanks for your respone.
We got no apps outside the usual ones.
From my point of view most people in our company use cloud as data storage only.
My cronjob seems to be okay, in Log I found some PHP errors repeated:

reset() expects parameter 1 to be array, null given at /var/www/html/apps/files_versions/lib/storage.php#785
ksort() expects parameter 1 to be array, null given at /var/www/html/apps/files_versions/lib/storage.php#784
Invalid argument supplied for foreach() at /var/www/html/apps/files_versions/lib/storage.php#761
Undefined index: by_file at /var/www/html/apps/files_versions/lib/storage.php#761
Undefined index: all at /var/www/html/apps/files_versions/lib/storage.php#759

Are there any ideas on that? Could this be the reason?
I did not check code integrity, but I did some update and before and after it was the same topic.
So a check is needed?

I don´t know why this happened. But my users are not happy with it :frowning:

Regards

Maik


#4

Could be related. Are you running the latest version of the 9.0-branch? https://owncloud.org/changelog/#latest9.0

Which php version are you using? Which OS? SELinux (CentOS)?


#5

Hey tflidd,
thank you for your response.
I am running Owncloud 9.0.10, which seems to be the latest version in my case.
I am using php 5.5.9 from ubuntu repository.
I am not sure but from my point of view did it work till the last updates.
I am using Ubuntu.

Any suggestions?

Regards

Maik


#6

The errors you a citing above are strange, perhaps open a new topic on the bug tracker.

Similar topic on nextcloud: https://help.nextcloud.com/t/custom-quotas-keep-getting-reset/15194


#7

Hey,
thank you for your response.
I opened up a bug report: https://github.com/owncloud/core/issues/28380
I hope to get a solution there, this seems to be very strange.
I added your link to it.

Thank you :slight_smile:

Regards

Maik


#8

Hey,

we have the same problem but for a single LDAP account. Has no one found a solution ?

Red Hat Enterprise Linux release 7.3
Owncloud 9.1.6

Regards

Laurent


#9

Hey Laurent,
we found a solution with the help from owncloud.
In our case it was a general setting, which comes with newer versions.
So this was the reason. We updated it, restarted the system and everything works.

Is this helpful to you?

Regards

Maik