Bad gateway 502 error

Hey all,

Sorry for the newbie question here. I installed my ownCloud using the appliance a month or so ago. It was working great. I could set up connections to two different desktops and sync folders. I had users set up as well. I ran into an issue uploading some files (got an error saying there wasn’t enough space), so I started tinkering with things in the virtualBox and tried to add some virtual storage. I decided to punt on that for the day and wanted to get things back to they way they were, but now my browser isn’t able to connect to the server, giving me a 502 Bad Gateway error. I tried restarting the apache server to no avail. I wanted to make sure the ownCloud within the virtualBox was able to talk to other devices on my network, so I pinged my router (wired) and cellphone (on WiFi) with no problems. I’m at a loss for what to do here. Can anyone help me figure out why I can’t see the ownCloud login screen?

Thanks for whatever help you can provide. Again, sorry if this is a newbie question.


Steps to reproduce

  1. Tried logging in to local IP for OwnCloud
  2. Got the 502 error

Expected behaviour

Expect to see the Owncloud login page

Actual behaviour

Bad Gateway

The proxy server received an invalid response from an upstream server.

Apache/2.4.25 (Univention) Server at Port 80

Server configuration

Operating system: Univention 4.4-4 errata589, Codename: Blumenthal. Installed using the Owncloud Appliance

Web server: Apache

Database: Not sure

PHP version: 7.0.33

ownCloud version: 10.3.2-1

Updated from an older ownCloud or fresh install: Fresh install

Where did you install ownCloud from: ownCloud’s website

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

Cannot login to ownCloud

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser: Firefox

Operating system: Ubuntu 20.04 codename: focal


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...


maybe i’m wrong but i think the following topic is exactly discussing the same issue. Only the 402 error in the topic title seems to me wrong because later the user is mentioning the same 502 error in the text.

I’ve adjusted the typo in the title of the other post.
See if this solves your issue and mark this topic as solved if it does.

1 Like