Base DN could not be auto-detected, please revise credentials, host and port


#1

I have installed the LDAP User and group backend, but getting no luck with the configs.

I have a number of other web-apps using LDAP successfully, but no luck with owncloud.
* My example AD domain is: hosting.mydomain.com
* My AD DC (LDAP) is: 192.168.100.10
* I have created a user (in the Users OU): owncloud

In owncloud I have specified the server this way:
l* dap://192.168.100.10 (it auto-detects port 389)
* uid=owncloud,DC=hosting,DC=mydomain,DC=com
* password

I am unable to detect base DN, and even when I enter base DN: DC=hosting,DC=mydomain,DC=com, no luck. Any ideas?


#2

Hi unsichtbarre,

Please consider that the User DN is the name as DN of a user who has permissions to do searches in the LDAP directory. So your "owncloud" user must have the right permissions.

You may also want to double-check your syntax: make sure there are no blank spaces in the "User DN" and "Base DN" fields.


#3

Thanks. I made "owncloud" a Domain Admin just for the sake of testing. "owncloud" is in the Users OU.

There are no spaces.

Do
I need: uid=owncloud,CN=Users


#4

Yes, very likely you need the CN as well. Have a look at: https://doc.owncloud.org/server/latest/admin_manual/configuration/user/user_auth_ldap.html?#server-tab


#5

Thanks for the help. I have specified every variation of:

uid=owncloud,cn=Users,dc=hosting,dc=mydomain,dc=com

That I can think of. nothing works. Logfiles contain this:

{"reqId":"qbId4jcq4ou5HGeOUwTo","level":2,"time":"2017-08-03T20:21:02+00:00","remoteAddr":"192.168.100.20","user":"admin","app":"user_ldap","method":"GET","url":"\/owncloud\/index.php\/settings\/admin\/log\/download","message":"Configuration Error (prefix s01): No LDAP Login Filter given!"}
{"reqId":"qbId4jcq4ou5HGeOUwTo","level":2,"time":"2017-08-03T20:21:02+00:00","remoteAddr":"192.168.100.20","user":"admin","app":"user_ldap","method":"GET","url":"\/owncloud\/index.php\/settings\/admin\/log\/download","message":"Configuration Error (prefix s01): login filter does not contain %uid place holder."}


#6

OK, I got it, but for me the documentation is completely incorrect.

For server, enter: ldap://102.168.100.10 Port is: 389
For the next line, enter ONLY the user name: owncloud (no CN=, no uid=)
For the password, enter the password
For the base DN: cn=Users,dc=hosting,dc=mydomain,dc=com

Now it works


#7

Nice that it is now working. I can ensure you that the User DN can also be in the form of:

uid=owncloudsystemuser,cn=sysusers,dc=my-company,dc=com

So the documentation is absolutely correct.

Please mark this as solved if you are not experiencing this issue anymore. Thanks :slight_smile:


#8

Thank you for all of the help!

I have tried: uid=owncloudsystemuser,cn=sysusers,dc=my-company,dc=com

As in: uid=owncloud,cn=Users,dc=hosting,dc=mydomain,dc=com

And it does not work. Owncloud is unable to "Detect base DN" and "Test Base DN" creates an error!