Basic client problems

hello all,

I’ve had Owncloud running in virtualbox for a while, works great. I can access my files with finder on a mac, browser and client.

I decided to move to a dedicated server. I installed Unbuntu 16.04 as my server video wasnt supported in later versions. I had to upgrade PHP to PHP7.1, all went well and I’m able to login, access my public files using a browser. The install seemed a little more manual, of course, but I think I have it working.

couple issues:

  1. I don’t get the admin screen when I login as I did with the appliance. So if if go to the server using a browser, I just get the default apache2 page. I assume something has to be setup there.

  2. I can’t get the client to work on win10. So again, I can access public folders with a browser but the client just times out. even with This same client works with the appliance (different address of course).

Just basic pointers are all I need.



  1. I figured out how to admin remotely. So no big deal there.

  2. The issue with the client is that I can login with http:// but not securely with https:. So now that I have identified the issue I should be able to find the problem,


the client problem was related to ssl. I don’t understand ssl that well but I went through the process of creating a self-signed certificate. I’m getting connections for both HTTP and HTTPS connections and I think the http connections are redirected to https?? But the https connections come back as unsecure. Is that typical? I’ll do more reading but I would say at this point I am on my way.




i think self-signed certificates are always showing up as insecure by default.

1 Like

If it works with http, then it’s a matter of setting up the SSL certificate and make the client accept it.

Using self-signed certificate will (and should) pop up a warning in all the clients, including the desktop client. This is normal because neither your system nor the desktop client trust that certificate. You’ll need to manually accept that certificate in each client and tell them to trust that self-signed certificate.