Blank White Homepage & SSL Warnings

Hi I am a freshman user and I just installed ownCloud on my Ubuntu 20.04 LAMP server (local dev) My LAMP installation is located at `/var/www/html/owncloud/

`

Problem: owncloud serves blank white page at https://someothersite.org/

useful info: I already have multiple wordpress installations using an OpenSSL certificate pointing to /var/www/html/ on port 443
I CAN successfully reach https:// someothersite .org/ phpmyinfo.php #your site limits me to 2 urls in a post so I am adding " spaces" for clarity

In my owncloud.conf file I have:

<VirtualHost *:443>

    ServerName someothersite.org 
    ServerAlias www.someothersite.org 
    
    # If this is the default configuration file we can use: 'ServerName localhost' or also 'ServerAlias localhost'.

    ServerAdmin info@thesolutiontopoverty.org

    ErrorLog ${APACHE_LOG_DIR}/someothersite.org.error.log
    CustomLog ${APACHE_LOG_DIR}/someothersite.org.access.log combined

    DocumentRoot /var/www/html/owncloud/
    
    <Directory /var/www/html/owncloud>
        Options None FollowSymLinks
        # Enable .htaccess Overrides:
        AllowOverride All
        Order allow,deny
        Allow from all
        Require all granted
    </Directory>
    
    #My Edit
    SSLEngine on
   SSLCertificateFile /etc/ssl/certs/apache-selfsigned.crt
   SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key

</VirtualHost>

In my default-ssl.conf file I have:

ServerAdmin info@someothersite.org ServerName localhost ServerAlias localhost
  DocumentRoot /var/www/html/

  ErrorLog ${APACHE_LOG_DIR}/localhost.error.log
  CustomLog ${APACHE_LOG_DIR}/localhost.access.log combined

  SSLEngine on

  SSLCertificateFile	/etc/ssl/certs/ssl-cert-snakeoil.pem
  SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

  <FilesMatch "\.(cgi|shtml|phtml|php)$">
  		SSLOptions +StdEnvVars
  </FilesMatch>
  <Directory /usr/lib/cgi-bin>
  		SSLOptions +StdEnvVars
  		DirectoryIndex index.php
        	AllowOverride All
        	Order allow,deny
        	Allow from all
        	Require all granted
  </Directory>

    BrowserMatch "MSIE [2-6]" \
  		nokeepalive ssl-unclean-shutdown \
  		downgrade-1.0 force-response-1.0

In my /etc/hosts file I have:

127.0.0.1	localhost 
127.0.0.1     someothersite.org

In my someothersite.org.error.log I have the following error:

[ssl:warn] [pid 32824] AH01906: someothersite.org:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[ssl:warn] [pid 32824] AH01909: someothersite.org:443:0 server certificate does NOT include an ID which matches the server name
[ssl:warn] [pid 32824] AH01906: someothersite.org:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[ssl:warn] [pid 32824] AH01909: someothersite.org:443:0 server certificate does NOT include an ID which matches the server name

Any tips?

Steps to reproduce

  1. download latest owncloud (wget),
  2. unzip owncloud,
  3. change file permissions,
  4. configure hosts file
  5. configure apache,
  6. restart apache && mysql
  7. visit owncloud home page

Expected behaviour

Tell us what should happen

Should see ownloud admin login page

Actual behaviour

Tell us what happens instead

blank white page loads at https:// someothersite .org #your site limits me to 2 urls in a post so I am adding " spaces " for clarity

Server configuration

Operating system:

Ubuntu 20.04

Web server:
Apache2

Database:
MySQL
PHP version:
7.3
ownCloud version: (see ownCloud admin page)
10.6
Updated from an older ownCloud or fresh install:
fresh install

Where did you install ownCloud from:
<download.owncloud<.org>/community/owncloud-complete-20201216.zip
Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

Check your browser dev console and apache error log for more detailed error messages.

It is most likely an apache misconfiguration.

Don’t use a self-signed cert?