Browsing DFS Shares


#1
version 10.0.9.5
versionstring 10.0.9
edition Community

Good morning all,

Starting to test out OwnCloud and running into some issues with DFS which seems to be a common theme here. Similar to other posts over the years the issue that is coming up is not being able to browse DFS targets when mounting the root of the Namespace. Adding the share directly works fine.

Sidenote: I can add the root of the DFS namespace and browse all subfolders (targets) as a Domain Admin but not as a normal user. As a normal user I must map to one of the shares directly.

Since the last post seems to be from three years ago, has anyone made any progress on this approach?

I would like to:
A: Set one external storage mount to \DFS\Share$ and be able to list all of the subfolder/targets that are hosted on that namespace.
B: Browse the DFS namespace via the Domain Namespace rather than the server namespace. domain.com\Share$ rather than servername.domain.com\Share$

Thanks for any advice!


#2

Well, I don’t think it is that common here. The search function mainly delivers your own post. Unfortunately I cannot help here.


#3

Check with smbclient from the same server where ownCloud is, using the same information. If smbclient can’t access to it, ownCloud won’t.


#4

Hello @alfredb. I guess there aren’t many individual posts regarding this after all. I kept coming across the same post on multiple platforms (OwnClowd Community & Github). Here is the other post I was referencing.


#5

Good morning @jvillafanez.

Thanks for the tip.
I just tested with smbclient on the OwnCloud server and was able to successfully browse the DFS namespace at the root level. Checking with the same account in OwnCloud UI did not list the folders…
Verified the paths/creds/etc are the same in both tests.


#6

Wow lol. @alfredb @jvillafanez

Okay, you can disregard the issue.

Comparing my settings I noticed the following:
Using smbclient I used the domain shortname for “WORKGROUP”. (“Domain” instead of “Domain.Com”)
Initially in the GUI I set the “Domain” to the full domain name. Changed this to the short name and all the folders were listed.

While this does work I still don’t understand why a domain admin can see the full list with the original settings.


#7

I guess that’s part of the windows’ setup and configuration that I don’t want to know :no_good_man: