Building owncloud client on Windows 10


#1

Expected behaviour

Build owncloud client on windows 10

Actual behaviour

Following the tutorial, when I try to build (step 7) the source code I get this error

System configuration

OS: Windows 10

ownCloud client version: branch master

Qt version: 5.12.0


#2

You can also check the new approach:
https://owncloud.org/news/interview-kde-craft-improves-owncloud-client-build-process/


Win build fails
#3

Thanks Michael, but it seems there’s a problem in step 2

  1. First, setup Craft.
  2. Install the owncloud blueprints craft –add-blueprint-repository https://github.com/owncloud/craft-blueprints-owncloud.git
  3. Tell craft to build ownCloud from git with craft –set version master owncloud-client, and install ownCloud: craft owncloud-client
  4. If you now want to get your changes in, switch to the owncloud clone: cd owncloud-client and apply your changes.
  5. Now you can run craft –make owncloud-client to build with your changes.

Whe I run it I get this message

Failed to find –add-blueprint-repository:
Craft was unable to find –add-blueprint-repository

I also tried to build the client with Qt Creator but I get the same error shown in the screenshot


#4

Thank you very much for your feedback!

Maybe @dschmidt , the author of the blogpost can have a look the next few days…


#5

Hey,

maybe there is some sort of formatting issue on the blogpost. From my experiences most of such commands in the linux world looks like (note the double dash):

--add-blueprint-repository


#6

Indeed, that looks very wrong. I’ll let Emil know who actually did the blog post, I was only interviewed :wink:


#7

I talked to the maintainer. Known wordpress issue apparently: https://geeksterminal.com/wordpress-double-dash-problem/1399/


#8

@salvatoreucchino does it work with --add-blueprint-repository?


#9

fixed :slight_smile: the blogpost displays the double dashes again.


#10

Thanks @lefherz but I have noticed another error when you run the command craft --set version master owncloud-client, it says Invalid option version. I’m trying to complete these steps to build owncloud.


#11

@dschmidt what could be the reason?


#12

This is the error I get when I try to install owncloud-client through the command craft owncloud-client without --set version master owncloud-client

What am I doing wrong?


#13

Hello,

Well try to don’t use the “–set version master owncloud-client” command and go straight to “craft owncloud-client”.


#14

My error is a bit different, or maybe its not an error and I don’t know something.

I have opened an issue in github, but I was send here. My issue - https://github.com/owncloud/client/issues/7011

I crafted with kde craft, but can someone tell me what to do next? How to make installation file or launch the owncloud client?

I don’t know if am in the right spot after build but that’s what kind of error I get now:

Any ideas?


#15

@dschmidt any idea? Recommendations how to debug? Log?


#16

@timetofaceit I did it but I got the error during the building process. At least you completed this step. Can you tell me all your steps before the building process and your configuration? Thanks


#17

@salvatoreucchino @timetofaceit Maybe check the new documentation pull request from @dschmidt about building the client with Craft:

We’d love to hear your feedback! Is there something that needs more detailed explanation?


#18

Thank you @michaelstingl and @dschmidt. I’ll follow new doc and I’ll keep you updated.


#19

I followed steps of new doc and…it worked perfectly! Thank you guys. Just one more question: if I want to make some changes and rebuild the client to see them, what do I have to do?


#20

Fork the client repo on GitHub.com, then build from your repo. (keep submodules)