Building the windows installer

client-development

#1

Hi everyone,
I get the following error when i want to build the windows installer of the client 2.3

Step 7 : RUN zypper --non-interactive --gpg-auto-import-keys ar http://download.opensuse.org/repositories/windows:/mingw/openSUSE_42.1/windows:mingw.repo
---> Running in f5cb05d4191b
File '/repositories/windows:/mingw/openSUSE_42.1/windows:mingw.repo' not found on medium 'http://download.opensuse.org/'

Problem encountered while trying to read the file at the specified URI:
ABORT request: Aborting requested by user
Abort, retry, ignore? a/r/i/? shows all options: a
The command '/bin/sh -c zypper --non-interactive --gpg-auto-import-keys ar http://download.opensuse.org/repositories/windows:/mingw/openSUSE_42.1/windows:mingw.repo' returned a non-zero code: 4

Can anyone help me with this issue?
I am using OpenSuse_Leap 42.1


#2

Hey @aknobbe! The cross-compilation image for windows installers was recently updated (see https://github.com/guruz/docker-ownCloud-client-win32/pull/1/files) to update openSUSE's 42.1 references to its new name precisely to prevent what you're seeing. Run docker pull guruz/docker-owncloud-client-win32 to test it out!

Hope it helps!


#3

Hi alfageme,

Thank you for your reply.
I did the test with the new docker,

Just to be sure, i run the following command after pulling the docker:
sudo docker run -v "$PWD:/home/user/client" guruz/docker-owncloud-client-win32 /home/user/client/admin/win/docker/build.sh client/ $(id -u)

After the .exe is build and i run this in Windows the installation goes great.
When i run the client i get the following errors:

Entry Point Not Found : The procedure entry point __divmoddi4 could not be located in the dynamic link library C:\Program Files (x86)\Boxu\icui18n56.dll.
And
Application popup: Boxu.exe - Entry Point Not Found : The procedure entry point __divmoddi4 could not be located in the dynamic link library C:\Program Files (x86)\Boxu\Qt5Gui.dll.


#4

@aknobbe hm... just checked and indeed something's looking wrong on the generated installers. We're trying to determine what's failing in the toolchain used in the compilation. In the meantime, I've uploaded an snapshot I have from the old image to https://hub.docker.com/r/alfageme/docker-owncloud-client-win32/ (use docker pull alfageme/docker-owncloud-client-win32:snapshot)

Could you verify this one works? Thanks!


#5

Hi alfageme, i can't get this docker image started


#6

@aknobbe you sure? I just tried pulling it:

root@ubuntu16_04:/# docker run -ti --name client_build alfageme/docker-owncloud-client-win32:snapshot
Unable to find image 'alfageme/docker-owncloud-client-win32:snapshot' locally
snapshot: Pulling from alfageme/docker-owncloud-client-win32
a02ba3067567: Pull complete
c7c21b6f2fd1: Pull complete
08dd27444f01: Pull complete
81819cced7d5: Pull complete
bc186737de6d: Pull complete
fe3b6d4f9b21: Pull complete
df751c5869d0: Pull complete
288cddea3c24: Pull complete
4608a2b1d6d8: Pull complete
a56665a0aef3: Pull complete
Digest: sha256:b0f26468a161fd5a80385abd355f87dd91a81742ce1350c94ed83a8688ce7814
Status: Downloaded newer image for alfageme/docker-owncloud-client-win32:snapshot
bash-4.2#

... and built the client inside it without trouble :confused:


#7

I have it running.

At the end of the build i get the following error:

Pack Error: Problem running NSIS command: "/usr/bin/makensis" "/home/user/client/build-win32/_CPack_Packages/unused/NSIS/project.nsi"
Please check /home/user/client/build-win32/_CPack_Packages/unused/NSIS/NSISOutput.log for errors
CPack Error: Problem compressing the directory
CPack Error: Error when generating package: ownCloud
Makefile:138: recipe for target 'package' failed
make: *** [package] Error 1


#8

@aknobbe try using https://github.com/owncloud/administration/blob/master/jenkins/win32_build/compile_client.sh
rather than https://github.com/owncloud/client/blob/master/admin/win/docker/build.sh. I think that script might be a bit outdated/incomplete. I wrote some instructions in the past here:

P.S. Are you trying to apply some theming? maybe something there is causing makensis to fail - what does NSISOutput.log say?


#9

Great, i have made my first windows client :slight_smile:
Thank you very much for your support alfageme

One other question, i am not sure this is related but when i install the new client there is an issue with the Windows Explorer integration.

I can fix it after running below in CMD and restart the computer.

regsvr32.exe "C:\Program Files (x86)\MyAppName\shellext\OCOverlays_x64.dll"

It seems like the client is not registering the dll


#10

Small correction, i need to restart my computer withoud the command and then it works to.