Caldav won't sync on Thunderbird

calendar
10

#1

Steps to reproduce

  1. Copy CalDav link from calendar app
  2. Paste into thunderbird's lightning app as caldav link
  3. Cry

Expected behaviour

The calendar should be found and synchronised. I have this working via the davdroid app on my phone and when I got to the link in my web browser I get the "This is the WebDAV interface. It can only be accessed by WebDAV clients such as the ownCloud desktop sync client." So the link seems to work fine and davdroid can sync my calendars (and contacts) correctly, but Thunderbird/lightning cannot

Actual behaviour

Calendar goes "greyed out" with the thunderbird logging saying the following (Main2 is what I called the calendar in thunderbird, mainics is the name assigned by the calendar app)

CalDAV: Retrieving server info from cache for Main2
[calCachedCalendar] Performing playback operation add on 0 items to Main2
[calCachedCalendar] Performing playback operation modify on 0 items to Main2
[calCachedCalendar] Performing playback operation delete on 0 items to Main2
[calCachedCalendar] Doing changelog based sync for calendar https://abc.xyz/remote.php/dav/calendars/user/mainics/
CalDAV: send: <?xml version="1.0" encoding="UTF-8"?>
<D:propfind xmlns:D="DAV:" xmlns:CS="http://calendarserver.org/ns/" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><D:resourcetype/><D:owner/><D:current-user-principal/><D:supported-report-set/><C:supported-calendar-component-set/><CS:getctag/></D:prop></D:propfind>
CalDAV: Status 401 on initial PROPFIND for calendar Main2
Error: [calCachedCalendar] replay action failed: null, uri=https://abc.zyx/remote.php/dav/calendars/user/mainics/, result=2147500037, operation=[xpconnect wrapped calIOperation]

Server configuration

Operating system:
Debian Jessie

Web server:
Nginx

Database:
mysql

PHP version:
5.6.33-0+deb8u1

ownCloud version: (see ownCloud admin page)
10.7.2

Updated from an older ownCloud or fresh install:
Fresh install though same nginx config as from 8.2.x

Where did you install ownCloud from:
Source

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

"No errors have been found."

The content of config/config.php:

    "config": {
        "instanceid": "ocgcnc7xim5w",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "cloud.jakecowton.net"
        ],
        "datadirectory": "\/srv\/secure\/owncloud\/data",
        "overwrite.cli.url": "https:\/\/cloud.jakecowton.net",
        "dbtype": "mysql",
        "version": "10.0.7.2",
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "installed": true

List of activated apps:

Enabled:
  - calendar: 1.5.7
  - comments: 0.3.0
  - configreport: 0.1.1
  - contacts: 1.5.4
  - dav: 0.3.2
  - encryption: 1.3.1
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_external: 0.7.1
  - files_sharing: 0.10.1
  - files_texteditor: 2.2.1
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - market: 0.2.3
  - notifications: 0.3.2
  - ownbackup: 17.7.0
  - provisioning_api: 0.5.0
  - security: 0.0.2
  - systemtags: 0.3.0
  - tasks: 0.9.6
  - templateeditor: 0.2
  - twofactor_totp: 0.4.4
  - updatenotification: 0.2.1
Disabled:
  - external
  - theme-example
  - user_external

Are you using external storage, if yes which one: No

Are you using encryption: yes

Are you using an external user-backend, if yes which one: No


#2

Did you try to clear the calendar cache in Thunderbird?


#3

Yes, I've tried clearing the cache and same result.


#4

Does it work if you use the direct link to the calendar? (On owncloud click on the "..." Next to the individual calendar and choose link). Copy that link into Thunderbird.

That is how I set up mine.


#5

@Schnabeltier: I may be wrong, but I assume it's a matter of your setup and/or environment. Code 401 means Unauthorized. And a quick google search with the result code 2147500037 mentions some Windows10 networking issues.


#6

@dbolton yes I've tried this and it is immediately greyed out. I've tried both the old and new caldav links

@alfredb It very well could be. However, to clarify, this is after "upgrading" a system. I was previously on a much older version so I dropped the DB, upgraded the owncloud files and let it rebuild the DB to essentially create a fresh install. Nothing within nginx or anything else has changed and everything worked perfectly fine previously.