Calendar - cannot create or import calendars or events

help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. Install Owncloud via Installatron (since that is the only option my provider gives me) -> Success
2. Log in as Admin -> Add apps Calendar and Contacts
3. Create new user
4. Log in as user, On top of the screen I see "This operation is forbidden". However I do not see any definition of what is forbidden anywhere.
5. Files -> Calendar, Calendar screen opens.
6. New Calendar and New Subscription always show hourglass.
7. Try to create calendar -> Site keeps showing Personal, but never finishes
8 Try to import (small) ICS file with calendar info.
9. Settings and Import ->Import ICS file -> select file -> Apply -> Import scheduled. Nothing more.

Expected behaviour
I expect the calendar to be created or imported.

Actual behaviour
Import scheduled. System locks up.

Server configuration
Operating system: Linux
Web server: Apache 2.4.25
Database: MariaDB 5.5.41
Php 5.5.38
ownCloud version : 9.1.4
Fresh install:

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Debug 	DeleteOrphanedItems 	0 orphaned comment read marks deleted 	2017-03-01T14:57:43+00:00
Debug 	DeleteOrphanedItems 	0 orphaned comments deleted 	2017-03-01T14:57:43+00:00
Debug 	DeleteOrphanedItems 	0 orphaned user tag relations deleted 	2017-03-01T14:57:43+00:00
Debug	DeleteOrphanedItems	0 orphaned system tag relations deleted	2017-03-01T14:57:43+00:00
Debug	DeleteOrphanedSharesJob	0 orphaned share(s) deleted

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
EMPTY

#2

Do you get any messages in the apache error log, too?


#3

Hi Skriesch,

Been away and thus was not able to log in and reply earlier.

Unfortunately I do not have access to the Apache log. My Owncloud is running on a hosted system, to which I have phpMyAdmin and DirectAdmin access, but no shell access. I can only install and remove applications through Installatron, not in any other way. If I can figure out what is hindering here, I should be able to get my hoster to fix things.
I do have an error log, which might give some insights.

Start log

[Wed Mar 01 13:47:57.600854 2017] [access_compat:error] [pid 11018] [client 999.999.999.999:61923] AH01797: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/remote.php
[Wed Mar 01 13:48:01.566716 2017] [access_compat:error] [pid 11180] [client 999.999.999.999:61949] AH01797: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/remote.php
[Wed Mar 01 14:29:44.900168 2017] [authz_core:error] [pid 15762] [client 37.17.211.50:30014] AH01630: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/.htfhclor6y9isy.data/htaccesstest.txt
[Wed Mar 01 14:32:47.318962 2017] [authz_core:error] [pid 16350] [client 37.17.211.50:23161] AH01630: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/.htfhclor6y9isy.data/htaccesstest.txt
[Wed Mar 01 15:39:50.705359 2017] [authz_core:error] [pid 23620] [client 37.17.211.50:42459] AH01630: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/.htfhclor6y9isy.data/htaccesstest.txt
[Wed Mar 01 15:57:55.550532 2017] [authz_core:error] [pid 26020] [client 37.17.211.50:59812] AH01630: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/.htfhclor6y9isy.data/htaccesstest.txt
[Wed Mar 01 16:07:27.280196 2017] [access_compat:error] [pid 26752] [client 999.999.999.999:62451] AH01797: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/remote.php
[Wed Mar 01 16:07:37.065551 2017] [access_compat:error] [pid 27226] [client 999.999.999.999:62463] AH01797: client denied by server configuration: /home/usernamexxx/domains/domainxxx/public_html/dav/remote.php

End Log (obfuscated to remove private information)

Hope this helps to get to the bottom of my problem.

Thanks in advance,

Patrick


#4

Hi,

this shows there is a misconfiguration on server side within the webserver. A few pointers are given at the following FAQs and documentations:

https://doc.owncloud.org/server/latest/admin_manual/issues/general_troubleshooting.html


#5

Hi,

I have contacted my Hoster to see if they can adjust the settings. I will keep you informed of any progress.
Thanks so far,

Patrick