Calendar Not Working/Only Spinning Icon

calendar
9.1.x

#1

I have my own domain which is hosted by a third-party and using cPanel, I have installed ownCloud 9.1.4 via the Installatron Applications Installer... As you can guess from the title above, I have also installed the ownCloud "Calendar" application, using ownCloud's own application browser.

This is a "clean" installation of ownCloud, as I had to completely remove and re-install ownCloud due to an unrelated issue (an upgrade that broke ownCloud).

The ownCloud "Files" and "Notes" applications both seem to be working, regardless of whether I am using the web-based interface or a compatible client... But when I select "Calendar", things go pear-shaped.

Essentially, all I see is a spinning circle to the left of "Personal" (i.e. my default calendar) which never goes away and in the case of Mozilla Firefox, it causes ownCloud to "freeze" within the web page (this doesn't seem to happen with Vivaldi - it just sits there with the spinning circle).

Furthermore, Mozilla Thunderbird is unable to connect to my calendar using CalDAV - it shows a padlock icon with the error message "The calendar ownCloud is momentarily not available" when you hover over it.

I have tried creating entries in the web-based interface, but these are neither saved (due to the aforementioned "freezing"), nor are they synchronized to any of my devices. The reverse is also true - entries made on my smartphone are not synchronized back to my ownCloud Calendar, despite my synchronization application ("CalDAV-Sync" by "dmfs GmbH") stating that the synchronization was successful.

Any help in correcting this issue would be appreciated.

--

UPDATE: The complete log from ownCloud is viewable here.


#2

Could you provide the log? Usually it's in /var/www/owncloud/data/owncloud.log or in the admin tab, set it to debug and download the logfile.

Then we could have a better look at the problem.

Also - when you say clean, do you mean completely wiped hard disk or did you just remove owncloud?

If possible - I would try purge owncloud, especially delete the database.


#3

When I say "clean", I meant remove and re-installing ownCloud - I use a third-party to host my domain, so I do not have access to the actual disks.

I tried to upload the log, but apparently new users do not have the permission to upload attachments and it's to big for a forum post...

As for "purging", if you're referring to this in the context of say, a Linux-based operating system, I do not have the ability to do this as I do not have physical access to the server and my host does not allow me to access a Terminal.

In saying this though, I was able to manually delete the ownCloud folder using cPanel's file manager, after previously removing ownCloud.


#4

If you don't have access to the database, things are difficult.
I suspect a database issue, that is hard to fix if you don't have access to it.

Could you post the last 10 - 20 lines / Messages from the log?


#5

In cPanel under the "Databases" section, I have:
* phpMyAdmin
* MySQL Databases
* MySQL Database Wizard
* Remote MySQL

I'm not gonna lie though - the stuff above is all new territory to me... I am pretty comfortable around computers, but I'll need someone to hold my hand with this.

As for the log, here's the last dozen lines or so...
{"reqId":"WT0CABt5QrkACEGVVnsAAAAI","remoteAddr":"168.1.99.224","app":"PHP","message":"Automatically populating $HTTPRAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0","level":3,"time":"2017-06-11T08:40:36+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/calendar\/v1\/config","user":"gregory.opera"}_
{"reqId":"WT0s6xt5QrkACdBl0zoAAAAA","remoteAddr":"168.1.99.224","app":"PHP","message":"Automatically populating $HTTPRAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0","level":3,"time":"2017-06-11T11:43:43+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/calendar\/v1\/config","user":"gregory.opera"}_
{"reqId":"WT0uKxt5QrkACd2rAdQAAAAD","remoteAddr":"168.1.99.224","app":"PHP","message":"Automatically populating $HTTPRAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0","level":3,"time":"2017-06-11T11:49:03+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/calendar\/v1\/config","user":"gregory.opera"}_
{"reqId":"WT2zHht5QrkADrQ6zy8AAAAJ","remoteAddr":"168.1.99.224","app":"PHP","message":"Automatically populating $HTTPRAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0","level":3,"time":"2017-06-11T21:16:19+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/calendar\/v1\/config","user":"gregory.opera"}_


#6

Ok, it's good that you have access to the log file.

Now you probably see that every new message form the log starts with

{"

followed with a lot of data, and the important part comes after

 "message":

What you can do, is copy the content of the log to an editor, like atom, sublime or your editor of choice, search for "message" and look for an error. That would be a good start to identify the problem.

Unfortunately, what you have posted so far from the log, is the same message 4 times over again, nothing I can do with that :slight_smile:


#7

I've uploaded the log to Pastebin here (I forgot that I had a Pastebin Premium account!).

If the forums will let me, I will also add this link to the OP...


#8

okay, I don't have a solution here.

the log just tells you that some files from a backup are inconstant, and something about automatic population of some file.

I would try to use the SQL tools that are available to you, and delete the ownCloud database. Something like "drop database owncloud" after you have acces to mysql.


#9

Okay,

So I deleted "operaid_ownc2" from cPanel-->Databases-->MySQL Databases-->Current Databases and "operaid_ownc2" from cPanel-->Databases-->MySQL Databases-->Current Users.

This left no entries on the "MySQL Databases" screen (cPanel-->Databases-->MySQL Databases).

Then I removed "owncloud" from "File Manager" (cPanel-->File Manager-->/home/operaid/public_html/owncloud), electing to skip "trash" and ensuring that the "trash" was empty, just in case.

Following this, I removed ownCloud using "Installatron Applications Installer" (which was whinging about something or other at this point - most likely because I had deleted the stuff above)(cPanel-->Software-->Installatron Applications Installer-->ownCloud-->Uninstall).

Then I re-installed ownCloud using "Installatron Applications Installer" and logged-in with the "admin" (ownCloud) account I elected to create.

And it's exactly the same issue - ownCloud works fine until I click "Calendar" (which I chose to install via my ownCloud admin account), then I just get the "spinning circle" next to "Personal".

Under "Admin" of my (ownCloud) "admin" account, there's an error that reads:
* Security & setup warnings
The PHP module 'fileinfo' is missing. We strongly recommend to enable this module to get best results with mime-type detection.
* You are accessing this site via HTTP. We strongly suggest you configure your server to require using HTTPS instead as described in our security tips.
* No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.

Please double check the installation guides :arrowupper_right:, and check for any errors or warnings in the log._

When I try to update from version 9.1.4.2 to version 9.1.6 via the Updater accessible in my "admin" account, it gets to the "Updating apps" section" and says:
Extracting source into /home/operaid/publichtml/owncloud/.htituqx8hmyjyf.data/updater-data/_oc_upgrade/9.1.6_
Extraction has been failed

[Symfony\Component\Process\Exception\RuntimeException]
The Process class relies on procopen, which is not available on your PHP installation._

upgrade:executeCoreUpgradeScripts

The ownCloud "config report" can be found here, and a fresh log can be found here.

--

UPDATE: Nevermind - I have managed to get an alternative solution for domain working, that is separate from ownCloud (i.e. using an unrelated software package)... It's the way I planned to have calendar synchronization originally, but it is a (mostly) superior solution.

Thanks for all your help though!