Can DL, Make folder, but no uploads

apps

#1

Actual behaviour

  • Tell us what happens
    Instant uploads used to work perfectly, but quit in mid-july (Android update I suppose) Now no uploads no matter which android client I've tried (Owncloud paid, beta, Nextcloud and owncloud.de) Can create folders in all and download is no issue. Each upload results in an error:
    You do not have permission to upload to this fol..
    Desktop (Windows client) with same credentials works perfectly from the same LAN.

Expected behaviour

  • Tell us what should happen

Steps to reproduce

Can this problem be reproduced with the official owncloud server?
(url: https://demo.owncloud.org, user: test, password: test)

Environment data

Android version:
6.0.1
Device model:
Samsung-SM-J320A
Stock or customized system:
Stock
ownCloud app version:
2.5
ownCloud server version:
9.x and 10.03.03

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

#2

For clarity sake, has anyone gotten any android app to upload using Android 6 or higher? Seems like a basic question, but I haven't found a clear cut answer anywhere.


#3

I just tried it, it works.

You wrote that you have 2 ownCloud servers, 9 and 10, is that correct?


#4

Thanks Dmitry - good to know that it can be made to work. I had 9.x and when this problem surfaced upgraded the server to 10. I figured out how to get at the client log and found this:
Existence check for https://XXXXXXX.com/owncloud/remote.php/webdav/ targeting for existence finished with HTTP status 401(FAIL)
I have no idea how to start troubleshooting this. There is a remote.php file in the owncloud folder, but no webdav folder.


#5

can you try to connect to the demo server and test if you can upload files there?

Can this problem be reproduced with the official owncloud server?
(url: https://demo.owncloud.org, user: test, password: test)

this one


#6

It appears that "test" password has been changed for the demo server. I've tried via web interface; "Wrong Password"


#7

Hi @jerry1, try again with test/test credentials, were restored yesterday,


#8

Thank you!
I was able to upload into the demo server. So, I guess that it's a server issue.