Can´t access after update to Server 10


#1

After updating the Server version, I had to update the PHP version in the installation of Ubuntu 14.04 where I have Owncloud installed, because I got a message that the PHP version should be at least 5.6.
I have installed PHP 7.1 and configured Apache2 to activate the new version of PHP and when accessing Owncloud I get these lines:

Exception occurred while logging exception: Failed to connect to the database: An exception occured in driver: could not find driver
#0 /var/www/html/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/html/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/html/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/html/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/html/owncloud/lib/private/DB/Connection.php(144): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /var/www/html/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, Object(Doctrine\DBAL\Driver\PDOMySql\Driver), Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))
#6 /var/www/html/owncloud/lib/private/DB/ConnectionFactory.php(145): Doctrine\DBAL\DriverManager::getConnection(Array, Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))
#7 /var/www/html/owncloud/lib/private/Server.php(529): OC\DB\ConnectionFactory->getConnection(‘mysql’, Array)
#8 /var/www/html/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server))
#9 /var/www/html/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet(‘DatabaseConnect…’)
#10 /var/www/html/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query(‘DatabaseConnect…’)
#11 /var/www/html/owncloud/lib/private/Server.php(1213): OC\ServerContainer->query(‘DatabaseConnect…’)
#12 /var/www/html/owncloud/lib/private/Server.php(404): OC\Server->getDatabaseConnection()
#13 /var/www/html/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server))
#14 /var/www/html/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet(‘AppConfig’)
#15 /var/www/html/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query(‘AppConfig’)
#16 /var/www/html/owncloud/lib/private/Server.php(1143): OC\ServerContainer->query(‘AppConfig’)
#17 /var/www/html/owncloud/lib/private/Server.php(583): OC\Server->getAppConfig()
#18 /var/www/html/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server))
#19 /var/www/html/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet(‘AppManager’)
#20 /var/www/html/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query(‘AppManager’)
#21 /var/www/html/owncloud/lib/private/Server.php(1411): OC\ServerContainer->query(‘AppManager’)
#22 /var/www/html/owncloud/lib/private/legacy/app.php(346): OC\Server->getAppManager()
#23 /var/www/html/owncloud/lib/private/legacy/app.php(110): OC_App::getEnabledApps()
#24 /var/www/html/owncloud/lib/base.php(577): OC_App::loadApps(Array)
#25 /var/www/html/owncloud/lib/base.php(994): OC::init()
#26 /var/www/html/owncloud/index.php(53): require_once(’/var/www/html/o…’)
#27 {main}

What steps should I follow to solve this problem?
Thanks…


#2

I would start with the database.

Is it running?

Is there a owncloud database?

Can you login with the credentials written in your config.php?


#3

Yes, it’s running:
mysql Ver 14.14 Distrib 5.6.24-72.2, for debian-linux-gnu (x86_64) using readlin 6.3

Yes, there is a owncloud database.

And I can login in MySql database with the credentials in config.php.


#4

I’m thinking you may be missing the MySQL module for PHP. See https://doc.owncloud.org/server/10.0/admin_manual/installation/source_installation.html#install-the-required-packages

When I upgraded OwnCloud on our old Ubuntu 14.04 appliance to 10.0.7, I used the following commands to update to PHP7.2.

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update

sudo apt-get install php7.2

apt-get install libapache2-mod-php7.2 openssl php-imagick php7.2-common php7.2-curl php7.2-gd php7.2-imap php7.2-intl php7.2-json php7.2-ldap php7.2-mbstring php7.1-mcrypt php7.2-mysql php7.2-pgsql php-smbclient php7.2-sqlite3 php7.2-xml php7.2-zip php-apcu

sudo a2dismod php5
sudo a2enmod php7.2

sudo service apache2 restart

This setup was temporary because I was just getting matching versions of PHP and OwnCloud as I migrated to Ubuntu 18.04.


#5

Perfect!
The Owncloud X is running… but appears a yellow banner in the top of the web “There were problems with the code integrity check. More information…”
There are 2 messages in red:

  1. The blocking transactional locking file should be configured to use memory-based blocking, not slow database-based blocking.
    (I follow the instructions to disable “File Locking” app but it’s not installed)

  2. Some files have not passed the integrity check. For more information on how to solve this problem see our documentation.
    The file with the list of invalid files is here: http://cloud.tcasa.es/owncloud/index.php/s/53doMxs2Fxlan5r

Thanks for the help…


#6

localhost? Maybe not, I guess. :grinning:


#7

Sorry…


#8

For #1, check out the “Configuration Recommendations Based on Type of Deployment” in this article.

We chose the second option for a “Small Organization, Single-server Setup.” Here’s the commands we used (this was on Ubuntu 18.04).

Set up redis for transactional file locking:

apt-get install redis-server
apt-get install php-redis
service apache2 restart

Add the following lines to /var/www/owncloud/config/config.php

‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ => array(
‘host’ => ‘localhost’,
‘port’ => 6379,
),

Restart apache

service apache2 restart

For #2, I’d start with going to the market and making sure all updates are installed there.


#9

Hey,

adding to what @chkdsk said i would also suggest to give the mentioned documentation a try:

IIRC this should also contain all required information to solve the integrity issue.


#10

Thanks!!
The warning #1 has disappeared following your instructions.

But for the warning #2, as you tell me, i look for in the market and all apps are updated (i only have 4 external apps).

Thnaks again.


#11

I have read the documentation referring to the error, but they are many many affected files and I do not know if it is something that affects the installation massively.
In this documentation, it explains each case:
FILE-MISSING: In principle I would have to recover them, but I do not know from where.
INVALID-HASH: There are 123 files modified after signing them digitally: I do not know how to solve this.
EXTRA-FILE: theoretically these 44 files could be deleted, because they are not in the file signature.json

In the documentation it puts a warning in red: Please don’t modify the mentioned signature.json itself.
I do not dare to do any editing of this file.

Thanks.


#12

Hey,

the related documentation is currently saying:

Reason:

  1. In the ownCloud core (that is, the ownCloud server itself) the files “index.php” and “version.php” do have the wrong version.

Solution:

  1. Upload the correct “index.php” and “version.php” files from e.g. the archive of your ownCloud version.

which is probably valid for the “FILE_MISSING” as well (if a file missing you need to upload it the same way you need to fix an wrong version of a file).

Yes, and thats why you should delete these files (not the signature.json) as explained in the documentation as well:

Reason:

  1. In the ownCloud core the unrequired extra file “/test.php” has been found.

Solution:

  1. Delete the “test.php” file.

For me it looks like the documentation provides all required information on how to solve this issue.


#13

Thanks for your help, but i think this: I check that almost all the files affected by the integrity are from the updater folder. I gather that the problem has coming in the update process.
I suppose that in the next update, if done correctly, this warning may disappear.


#14

Maybe, but I doubt.

I really would remove the entire updater folder, then install a replacement extracted from a tarball suitable to your installed version.


#15

Yes. That’s what I thought.
But in the repository of OwnCloud versions I can not find for the Ubuntu 14.04 version.
I do not know if extracting the files of the version for Ubuntu 16.04 I will have more problems later…


#16

I would give it a try, but SAVE the current updater folder first!. What can happen is, that afterwards your owncloud instance still has a non-working updater.

Use the last installed/upgraded owncloud package. I think, you should have a copy in your apt cache, but I’m not very familiar with ubuntu systems.


#17

I have done what you told me to replace the updater folder with the original package of version 10.0.10 and no warning appears.
Thank you all for the great help you have given me.


#18

Great to hear from your success. Could you please mark this thread as solved/solution? Thanks.


#19

I’m looking for… but i don’t see how mark as solved…