Can’t watch mp4 movie from Android App

Hi everyone,
first of all I apologize for my bad English

when I open videos via app I get the error: “the video cannot be reproduced”
the video only works if I download it before viewing.
On the PC with Chrome the problem does not occur

On apache I built a self signed certificate and I add this on trust certificate in Android System.
Can anyone help me ?

A thousand thanks

App Version 4.2.2
Owncloud Server 10.14.0
Android 14 HyperOS 1.0.4.0 (Xiaomi 13Tpro)

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'instanceid' => '****',
  'passwordsalt' => '****',
  'secret' => '****',
  'encryption.legacy_format_support' => 'true',
  'files_external_allow_create_new_local' => 'true',
  'trusted_domains' =>
  array (
    0 => '****',
    1 => '****',
  ),
  'enabledPreviewProviders' =>
  array (
    0 => 'OC\\Preview\\Image',
    1 => 'OC\\Preview\\Movie',
  ),
  'preview_max_dimensions' => '8000x6000',
  'datadirectory' => '****',
  'overwrite.cli.url' => '****',
  'dbtype' => 'pgsql',
  'version' => '10.14.0.3',
  'dbname' => '****',
  'dbconnectionstring' => '',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'owncloud',
  'dbpassword' => '****',
  'allow_user_to_change_mail_address' => '',
  'logtimezone' => 'Europe/Rome',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/owncloud/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/owncloud/apps-external',
      'url' => '/apps-external',
      'writable' => true,
    ),
  ),
  'installed' => true,
  'mail_domain' => '****',
  'mail_from_address' => '****',
  'mail_smtpmode' => 'smtp',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '****',
  'mail_smtpport' => '587',
  'mail_smtpname' => '****',
  'mail_smtppassword' => '****',
  'singleuser' => false,
  'maintenance' => false,
);

Hi @Gianmaria! Thanks for opening a new thread! :100:

Could it be that the video you’re trying to reproduce in stream is inside a space? Version 4.3.0 of the app includes a fix for this :smiley:. It will be released today in Play Store, so stay tuned and let us know if this solved your problem! We’ll also publish a new post in this same forum with the main news this release includes :+1:.

I hope you like the new version, and if you find any problem don’t hesitate to ask! :beers:

Ciao @Juanca
Unfortunately the new version 4.3.0 did not solve my problem. The mp4 file is located in a folder within my user’s main store.

Ciao @Gianmaria! Oh, I’m sorry the new version didn’t solve it :frowning_face:. Let’s take a deeper look.

First, make sure your server is accessed via secure HTTP, otherwise streaming could not work properly.

If that is the case (secure HTTP), then let’s obtain some logs from the app so that we can see what’s going on there. You can enable logs from Settings > Logging > Enable logging, and then you just have to perform the problematic action so that it is reflected in the logs. Once you have them, upload them here:

Link: https://infinite.owncloud.com/s/mmQiWqxfnbjrYtf
Password: Streaming-1

This is a folder I created for you in our internal instance. Don’t worry, no one but the team will be able to see what you upload there :smile:.

Keep us updated! :rocket:

yes, I use secure http but not on standard port 443 but on port 27443. I uploaded the log file.
Thanks a lot to everyone

Hi @Gianmaria! Thanks a lot for the logs!

It seems you are using a self-signed certificate, which is not valid for streaming, and so a SSL exception is triggered. This is a restriction imposed by the network library. The port number doesn’t mind in this case.

That’s what I can tell you about this :+1:

many thanks @Juanca
you were very kind

1 Like