Cannnot sync ownCloud from Thunderbird

help

#1

Hi guys,

we have the following issue, where I can not sync ownCloud from Thunderbird. The error is:

The calendar is momentarily not available.

It is really weird because at the same time I can sync the ownCloud calendar with iCalender on Mac OS and it works fine. I have installed
Lightning with both SOGo Add-ons. The SPDY is not enabled, so this could not be the problem in our case, I think. I have tried different scenarios, but without success.

Expected behaviour:
Calender in Thunderbird is synced with the calendar in ownCloud
Actual behaviour:
Error which says that the calendar is not available.

Versions:
OwnCloud 9.1.1
Mac OS X Sierra 10.12.01
Thunderbird 45.7.0
Lightning 4.7.4
SOGoConnector 31.0.3
SOGo Integrator 31.0.3
Server: nginx/1.10.0 (Ubuntu)

Server configuration

upstream php-handler {
server XXX.X.X.X:XXXX;
#server unix:/var/run/php5-fpm.sock;
}

server {
listen 80;
server_name _;
#server_name cloud.example.com;
# enforce https

#listen 443 ssl;
#server_name cloud.example.com;

#ssl_certificate /etc/ssl/nginx/cloud.example.com.crt;
#ssl_certificate_key /etc/ssl/nginx/cloud.example.com.key;


# Add headers to serve security related headers
# Before enabling Strict-Transport-Security headers please read into this topic first.
#add_header Strict-Transport-Security "max-age=15552000; includeSubDomains";
add_header X-Content-Type-Options nosniff;
add_header X-Frame-Options "SAMEORIGIN";
add_header X-XSS-Protection "1; mode=block";
add_header X-Robots-Tag none;
add_header X-Download-Options noopen;
add_header X-Permitted-Cross-Domain-Policies none;

#rewrite ^/.well-known/carddav /remote.php/carddav$1 permanent;
#rewrite ^/caldav(.*)$ /remote.php/caldav$1 redirect;
#rewrite ^/carddav(.*)$ /remote.php/carddav$1 permanent;
#rewrite ^/webdav(.*)$ /remote.php/webdav$1 redirect;

# Path to the root of your installation
root /XXXX/XXXX/XXX/XXX;

location = /robots.txt { 
    allow all;
    log_not_found off;
    access_log off; 
}

#location ~ ^/(?:.htaccess|data|config|db_structure.xml|README){
#deny all;
#}
# The following 2 rules are only needed for the user_webfinger app.
# Uncomment it if you're planning to use this app.
# rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
# rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;

location = /.well-known/carddav {
    return 301 $scheme://$host/remote.php/dav;
}
location = /.well-known/caldav {
    return 301 $scheme://$host/remote.php/dav;
}

location /.well-known/acme-challenge { }

#experimenting 20170124 henning shterion
#add_header Allow "GET, POST, HEAD PROPFIND" always;

# set max upload size
client_max_body_size 512M;
fastcgi_buffers 64 4K;

# Disable gzip to avoid the removal of the ETag header
gzip off;

# Uncomment if your server is build with the ngx_pagespeed module
# This module is currently not supported.
#pagespeed off;

error_page 403 /core/templates/403.php;
error_page 404 /core/templates/404.php;

location / {
   rewrite ^ /index.php$uri;
}

location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
    return 404;
}
location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
    return 404;
}

location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
    fastcgi_split_path_info ^(.+\.php)(/.*)$;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
   #fastcgi_param HTTPS on;

fastcgi_param modHeadersAvailable true; #Avoid sending the security >headers twice
fastcgi_param front_controller_active true;
fastcgi_pass php-handler;
fastcgi_intercept_errors on;
fastcgi_request_buffering off; #Available since nginx 1.7.11
}

location ~ ^/(?:updater|ocs-provider)(?:$|/) {
    try_files $uri $uri/ =404;
    index index.php;
}

# Adding the cache control header for js and css files
# Make sure it is BELOW the PHP block
location ~* \.(?:css|js)$ {
    try_files $uri /index.php$uri$is_args$args;
    #add_header Cache-Control "public, max-age=7200";
    # Add headers to serve security related headers (It is intended to have those duplicated to the ones above)
    # Before enabling Strict-Transport-Security headers please read into this topic first.
    #add_header Strict-Transport-Security "max-age=15552000; includeSubDomains";
    #add_header X-Content-Type-Options nosniff;
    #add_header X-Frame-Options "SAMEORIGIN";
    #add_header X-XSS-Protection "1; mode=block";
    #add_header X-Robots-Tag none;
    #add_header X-Download-Options noopen;
    #add_header X-Permitted-Cross-Domain-Policies none;
    # Optional: Don't log access to assets
   #  access_log off;
}

location ~* \.(?:svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$ {
    try_files $uri /index.php$uri$is_args$args;
    # Optional: Don't log access to other assets
    #access_log off;
}

}


#2

Most likely still an environmental issue in your webservers setup as already pointed out in your existing thread


#3

Thanks for your response! Perhaps we found a solution for the previous issue and as I said it works at this moment, but now the problem is other. So if it so, could you tell me where is the problem in the configuration file, because I read the link which you posted but nothing works for me.
Thank you in advance!


#4

Unfortunately there can be tons of reasons for such issues, thats why the pointed out FAQ in the other thread is that large. There is no single solution for such problems.

You mostly have to work your way again through this, check logfiles of your webservers, the bugtracker of Thunderbird and similar.