Cannot configure antivirus scanner ClamAV


#1

Steps to reproduce
1. Go to admin page
2. Edit antivirus options
3. Click on save

Expected behaviour
Antivirus options should be saved.

Actual behaviour
Antivirus options are not saved.

Comments

  • Edit these options from command line doesn't work either (sudo -u www-data occ config:app:set --value='socket' files_antivirus av_mode).
  • ClamAV and its daemon seems to work correctly:

# sudo -u www-data clamdscan /var/www/owncloud/data/admin/files/Documents/Example.odt 
/var/www/owncloud/data/admin/files/Documents/Example.odt: OK
----------- SCAN SUMMARY -----------
Infected files: 0
Time: 0.033 sec (0 m 0 s)

Server configuration
Operating system: Debian Jessie
Web server: Apache 2.4
Database: MySQL
PHP version: 5.6.30
ownCloud version (see ownCloud admin page): 9.1.4 or 9.1.3
Updated from an older ownCloud or fresh install: fresh install or upgrade from oC 8.2
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Nothing is logged for this


#2

Check the browsers error console for any errors which might happen during saving the settings. If there are no errors then please create a new bugreport at:


#3

There is already a bugreport concerning this issue: https://github.com/owncloud/files_antivirus/issues/107.