Cannot connect to calendar, caldav


#1

hi everyone

I run owncloud-9.1.5-1.el7.noarch off Centos 7

I have a calendar working, so it seems, but when I try to connect to it from Thunderbird and likes I fail.
Thunderbird just keeps asking to authenticate, which I do using same credential I login to Owncloud.
As caldav url I use the one Owncloud gives out when click "Link", but I also tried iCal from settings.

Strangely on apache's end, in log:

172.24.154.138 - - [24/Nov/2017:16:47:05 +0000] "PROPFIND /owncloud/remote.php/dav/ HTTP/1.1" 401 414
172.24.154.138 - - [24/Nov/2017:16:47:05 +0000] "PROPFIND /owncloud/remote.php/dav/ HTTP/1.1" 401 414
172.24.154.138 - - [24/Nov/2017:16:47:13 +0000] "PROPFIND /owncloud/remote.php/dav/ HTTP/1.1" 401 414

Is it Thunderbird problem, I am missing something trivial?


#2

Now that I've fixed OC logging, in logs when I try to connect in a web browser to URL of the caldav I see:

{"reqId":"Whh1EMzVRPxavlJ6IPQ9cgAAAAk","remoteAddr":"172.24.154.138","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\/1.1 401 No 'Authorization: Basic' header found. Either the client didn't send one, or the server is mis-configured, No 'Authorization: Basic' header found. Either the client didn't send one, or the server is mis-configured\",\"Exception\":\"Sabre\\DAV\\Exception\\NotAuthenticated\",\"Code\":0,\"Trace\":\"#0 [internal function]: Sabre\\DAV\\Auth\\Plugin->beforeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#1 \\/usr\\/share\\/php\\/Sabre\\/Event\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#2 \\/usr\\/share\\/php\\/Sabre\\/DAV\\/Server.php(446): Sabre\\Event\\EventEmitter->emit('beforeMethod', Array)\n#3 \\/usr\\/share\\/php\\/Sabre\\/DAV\\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#4 \\/usr\\/share\\/owncloud.clustered\\/apps\\/dav\\/lib\\/Server.php(178): Sabre\\DAV\\Server->exec()\n#5 \\/usr\\/share\\/owncloud.clustered\\/apps\\/dav\\/appinfo\\/v2\\/remote.php(30): OCA\\DAV\\Server->exec()\n#6 \\/usr\\/share\\/owncloud.clustered\\/remote.php(164): require_once('\\/usr\\/share\\/ownc...')\n#7 {main}\",\"File\":\"\\/usr\\/share\\/php\\/Sabre\\/DAV\\/Auth\\/Plugin.php\",\"Line\":188,\"User\":false}","level":0,"time":"2017-11-24T19:37:52+00:00","method":"GET","url":"\/owncloud\/remote.php\/dav\/calendars\/pe\/personal\/","user":"--"}

And I think that above logged info is identical when I try with Thunderbird.


#3

I did the following search https://central.owncloud.org/search?q=No%20Authorization%20Basic%20header%20found and found https://central.owncloud.org/t/webdav-caldav-client-authorization/3234 which seems to be about Thunderbird as well and which is pointing to various resources you could check.


#4

I've also searched a bit, but before I go on a search again...

When I use web browser, any, and I go to url(s) owncloud gives I cannot get pass authentication neither.
Does it not say it's not client problem?

Calendar's url eg. https://172.24.154.204/owncloud/index.php/apps/calendar/
Does the above url not look strange? This is what "Link" gives, then from "Settings & Import":
https://172.24.154.204/owncloud/remote.php/dav/
and as caldav for iOSes
https://172.24.154.204/owncloud/remote.php/dav/principals/users/me/

none of those urls I could, with web browsers get to authenticate successfully.


#5

I'm using URLs like http://mycloud/remote.php/dav/calendars/myusername/mycalendar/ which are working fine.


#6

Where from in your owncloud do you get that URL?


#7

I get this link if i'm clicking at the three "dots" at the left of one my calendars and choose "Link" there.