Cannot connect to ownCloud server after client desktop app update

Hello,
I am a non-technician, basic user of ownCloud. I have used ownCloud appp for several years to sync files between the laptop (Windows 10) and ownCloud server (v. 8.1.9). Today my client app has updated and I cannot connect to the server since (I can connect through the web browser, though). When I try to log in from the client app, it tries connecting forever, without effect. I tried to establish a new connection with this server but then at the credentials stage I get error message “Failed to fetch user display name”. All credentials are correct. For check I attempted to establish a new connection with another ownCloud server that I am using (v. 10.10) and I had no problem with that. Is it possible that after the update to version 3.0.0.9215 of the client app the older server version is no longer compatible? Are there any other solutions but asking the administrator to upgrade the server, which I have little impact on? I would very much appreciate any advice. Thanks.

You can download pre-3.0 version here:
Older Versions - ownCloud

Yeah, it was a pretty obvious solution, I guess, and actually worked. Thanks!