Cannot modify default language through config.php

Steps to reproduce

1.Modify config.php
2.Restart server

Actual behaviour

I modified 4 parameters of config.phpand replaced it in the container, but the default_language in it has no effect, but other parameters are effective. I modified ‘default_language “:” ja’, but the config report is still “default_language”: “en”

Server configuration

Operating system*:centos7.6
**Where did you install ownCloud from:**last docker 10.3.2

No errors have been found.

The content of config/config.php:

    "basic": {
        "license key": "***REMOVED SENSITIVE VALUE***",
        "date": "Fri, 21 Feb 2020 13:42:56 +0000",
        "ownCloud version": "",
        "ownCloud version string": "10.3.2",
        "ownCloud edition": "Community",
        "server OS": "Linux",
        "server OS version": "Linux 29db2842013a 3.10.0-1062.1.1.el7.x86_64 #1 SMP Fri Sep 13 22:55:44 UTC 2019 x86_64",
        "server SAPI": "apache2handler",
        "webserver version": "Apache",
        "hostname": "",
        "logged-in user": "admin"
    "stats": {
        "users": {
            "Database": {
                "count": 7,
                "seen": 7,
                "logged in (30 days)": 7
        "groups": {
            "OC\\Group\\Database": 1
    "config": {
        "apps_paths": [
                "path": "\/var\/www\/owncloud\/apps",
                "url": "\/apps",
                "writable": false
                "path": "\/var\/www\/owncloud\/custom",
                "url": "\/custom",
                "writable": true
        "trusted_domains": [
        "datadirectory": "\/mnt\/data\/files",
        "dbtype": "mysql",
        "skeletondirectory": "",
        "remember_login_cookie_lifetime": 129600000,
        "session_lifetime": 129600000,
        "default_language": "en",
        "dbhost": "db:3306",
        "dbname": "owncloud",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "dbtableprefix": "oc_",
        "log_type": "owncloud",
        "supportedDatabases": [
        "upgrade.disable-web": true,
        "overwrite.cli.url": "http:\/\/localhost\/",
        "htaccess.RewriteBase": "\/",
        "logfile": "\/mnt\/data\/files\/owncloud.log",
        "loglevel": 2,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "mysql.utf8mb4": true,
        "filelocking.enabled": true,
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "redis",
            "port": "6379"
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "version": "",
        "logtimezone": "UTC",
        "installed": true,
        "instanceid": "ocl82kqbnu43",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "php"
    "integritychecker": {
        "passing": true,
        "enabled": true,
        "result": []
    "core": {
        "OC_Channel": "beta",
        "backgroundjobs_mode": "cron",
        "first_install_version": "",
        "installedat": "1582267075.5035",
        "lastcron": "1582292521",
        "lastupdateResult": "[]",
        "lastupdatedat": "1582292031",
        "public_files": "files_sharing\/public.php",
        "public_webdav": "dav\/appinfo\/v1\/publicwebdav.php"

Hi @11137, As you said the language can be modified like explained in the documentation:

There will be a rule that overwrite the default language, and this is when the user chooses in the personal configuration a different one, that will be stored in the oc_preferences table

Please check if that user does not have an entry like this:

| snoopy  | core  | lang     | en  |

If so, then you have to remove it to force the user to have the default language.


Thank you for your answer. But the login page and new users have not changed, the Config Report is still “default_language”: “en”,

I see you are using the docker instance,

Did you change the environment variable to:


change en to the language you need


thanks ,env or docker-compose.yml ?

I recommend you try it out and report back

1 Like

is docker-compose.yml
thank you


I suppose that now it works :wink:

1 Like