Cannot see the files from external drive


#1

Steps to reproduce

  1. Install owncloud 10.0.10. I’ve followed the steps detailed in the following site: https://www.avoiderrors.com/owncloud-10-raspberry-pi-3-raspbian-stretch/
    I’m using an external drive containing existing folders and files
  2. connect to the web interface
  3. The existing folders and files are not displayed

Expected behaviour

I should be able to access the folders and files already saved on the external drive.

Actual behaviour

Folders and files are not displayed.

Server configuration

Operating system:
Linux raspberrypi 4.14.79-v7+

Web server:
Apache/2.4.25 (Raspbian)

Database:
mysql Ver 15.1 Distrib 10.1.37-MariaDB

PHP version:
php7

ownCloud version: (see ownCloud admin page)
owncloud 10.0.10

Updated from an older ownCloud or fresh install:
fresh install

Where did you install ownCloud from:
https://download.owncloud.org/community/owncloud-10.0.10.tar.bz2

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The webpage displays “No errors have been found.”

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.
  • comments: 0.3.0
  • configreport: 0.1.1
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_sharing: 0.11.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • market: 0.2.5
  • notifications: 0.3.5
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • updatenotification: 0.2.1
    Disabled:
  • encryption
  • external
  • user_external

Are you using external storage, if yes which one: local/smb/sftp/…
External drive mounted to /media/owncloudrive

Are you using encryption: yes/no
No
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
No

Client configuration

Browser:
Google chrome Version 72.0.3626.119 (Build officiel) (64 bits)
Operating system:
Windows 10 64

Web server error log

Insert your webserver log here


#### ownCloud log (data/owncloud.log)

Insert your ownCloud log here
{“reqId”:“Cuy9wS3I9ncNBAt0vkjK”,“level”:3,“time”:“2019-02-18T15:55:03+00:00”,“remoteAddr”:“192.168.1.30”,“user”:"–",“app”:“mysql.setup”,“method”:“P
OST”,“url”:"/owncloud/index.php",“message”:“Specific user creation failed: An exception occurred while executing ‘SELECT user FROM mysql.user WHER
E user=?’ with params [“oc_removed”]:\n\nSQLSTATE[42000]: Syntax error or access violation: 1142 SELECT command denied to user ‘admin’@‘loca
lhost’ for table ‘user’”}
{“reqId”:“Cuy9wS3I9ncNBAt0vkjK”,“level”:3,“time”:“2019-02-18T15:55:19+00:00”,“remoteAddr”:“192.168.1.30”,“user”:"–",“app”:“no app in context”,“meth
od”:“POST”,“url”:"/owncloud/index.php",“message”:"User backend OC\User\Database is returning home: /media/ownclouddrive/removed
for user: removed which differs from existing value: "}


#2

You have a faulty db setup:

My best guess here is: The directory was renamed or located somewhere else during setup.


#3

Hello,

Thanks for the feedback. I’ve done a fresh install and still get the same error message.

Are you aware of a solution?


#4

I assume you did it wrong again.

Verify each step, especially the db setup. I couldn’t find an admin@localhost as db-user.

And you omitted to post your anonymized config.php.


#5

Hello, below the begining of the content of the config file generated through the web UI
{
“basic”: {
“license key”: “REMOVED SENSITIVE VALUE”,
“date”: “Thu, 28 Feb 2019 16:21:07 +0000”,
“ownCloud version”: “10.0.10.4”,
“ownCloud version string”: “10.0.10”,
“ownCloud edition”: “Community”,
“server OS”: “Linux”,
“server OS version”: “Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l”,
“server SAPI”: “apache2handler”,
“webserver version”: “Apache/2.4.25 (Raspbian)”,
“hostname”: “192.168.1.29”,
“logged-in user”: “notrenuage”
},
“stats”: {
“users”: {
“Database”: {
“count”: 1,
“seen”: 1,
“logged in (30 days)”: 1
}
},
“groups”: {
“OC\Group\Database”: 1
}
},
“config”: {
“instanceid”: “oc2rbqez51i7”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“192.168.1.29”
],
“datadirectory”: “/media/ownclouddrive”,
“overwrite.cli.url”: “http://192.168.1.29/owncloud”,
“dbtype”: “mysql”,
“version”: “10.0.10.4”,
“dbname”: “notrenuage”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true
},
“integritychecker”: {
“passing”: true,
“enabled”: true,
“result”: []
},
“core”: {
“enable_external_storage”: “yes”,
“first_install_version”: “10.0.10.4”,
“installedat”: “1551358433.4322”,
“lastcron”: “1551370277”,
“lastupdateResult”: “[]”,
“lastupdatedat”: “1551370178”,
“public_files”: “files_sharing/public.php”,
“public_webdav”: “dav/appinfo/v1/publicwebdav.php”
},


#6

Your config looks reasonable. Could you fix the db-access problem or does it still occurs?

Here you should check the storage location in the settings->user panel You must enable the display via the gear-wheel bottom left.

Obviously it’s not pointing to the data directory on your mounted drive.


#7

Hello,

It seems that the db access problem does not occur.

I’m not sure how to check the data storage. The settings -> user panel menu is from web UI?


#8

Hello Alfredb,

So I manage to solve this by moving the folders under the follwing folder /media/ownclouddrive/owncloud/files.
Then running a scan with sudo -u www-data php occ files:scan –all will make them available on the web UI.