Cannot select address book to import

contacts
10

#1

Hi All,
I haven't found similar issues in the forum hence I'm writing. I would like to migrate from 8.2.2 to 10.0.0.4, but it is too risky to upgrade the current version, so my plan was to export my Contact address books and import them back into the new system. However it is not possible anymore to select in which address book I want to import the VCF file.
On top of that during the import it randomly list them and not assign to any known addressbooks.

Steps to reproduce

  1. Export from old Owncloud version the contacts into VCF file
    2.Import into new Owncloud 10.0.0.4
  2. All the contacts are mixed up, no assigned to any addressbooks

Expected behaviour

Like in the old version first select the address book and type, then the file to import.

Actual behaviour

Attached window not appear, just choose file directly.


#2

Hi All,
still no reaction on this bug. Is there any workaround how to import addressbooks? It always imports into the users default which keeps my business out for this upgrade.


#3

Hey,

personally if i think i have found a bug then i’m always reporting it to a bug tracker rather then to a user/community forums. I think posting this here might be the reason why you didn’t got a response yet. :confused:

From what i know the bug tracker of the contacts app is located below, maybe you have more luck when posting there?


#4

I think this is not considered as a bug, its more a strategy change of the developers.

AFAIR the support of multiple addressbooks in the frontend was dropped, a few years ago, even if the backend still supports them. Personally I never could understand nor accept this decision, thus I’m not really using the contacts app.

Fact is:

  • Many users have multiple addressbooks, for whatever reasons. (I’m managing my contacts currently in 5 books.)
  • Contacts app lists all in on single list, merged from all available addressbooks.
  • Grouping the contacts within the app is not a real solution, as you cannot export selected by groups etc.
  • You cannot disable a single addressbook, to get that contacts out of the “merged all” list.
  • Importing strictly targets the first addressbook, without any option to select.
  • Checking for dupes on import doesn’t exist.

I’ll stop here, to cool down. :wink:


#5

Hey,

if i’m clicking on the small “settings” cogwheel at the bottom left of the contacts app i’m seeing my currently used two address books and i’m also able to add new ones there. So it seems to me at least some parts of the frontend is still aware of multiple address books and could offer the user the possibility to chose in which address book the contacts should be imported.

I think its probably just a matter of some one to implement this possibility and thus i would call this a missing feature/functionality rather then a bug.


#6

No, that feature was present in the past, but dropped.
Having a look at calendar: Import to any calendar and calendars can be temp. disabled from view.


#7

Ah, thanks for the background information. Unfortunately i’m not that long around so i wasn’t aware that this was possible in the past. :confused:


#8

Hey,

i had some minutes left and searched a little bit around there. It seems there is a feature request / enhancement for this functionality tracked here:


#9

Yeah, I saw that also. But this issue is from 2016. The rant of the addressbook-removal was much earlier, I assume. I was searching for the discussions but couldn’t find it. Maybe it was in pre-central era, in the previous ownCloud forum.

But who cares these days. Contacts app is as it is. Use it or, like me, drop it.