Cannot Set Password for public link from desktop client

help

#1

Hello,

If I right client on a file or folder, go to owncloud, one of the option is to "copy public link to clipboard. I’m running Mac client 2.5.2.

It allows me to create the link. It shows an expiration. However the password is grayed out before and after link creation.

The web interface allows me to set a password on public links. without issue.

How can I set a password for a public link from desktop client 2.5.2?

Thanks,
Mike


#2

@mbrando Could you post a screenshot from the sharing settings in the admin UI on the ownCloud server?

@lazawan Could you try to reproduce?


#3

Here is the screenshot.


#5

@mbrando


#6

Hello,

Yes, that is exactly what I’m trying to do.

However, it will not allow me check the box to set the password. See attached.

Mac OS 10.13.6 with client 2.5.2


#7

@mbrand
it works fine

did you check if your server works properly ?
to ensure please use the demo server of owncloud
demo.owncloud.com and username : demo ,password :demo


#8

Hello,

Yes, I see it works with the demo server.

It does not work with my server. Any idea why my server would not work correctly with the desktop client?

Edited:
What is odd though is if I choose to “Enforce password protection for read-only links” it will allow the setting of a password.


#9

Maybe another app like password policy intereferes? Please post your config.report.


#10

which version of owncloud-server do you use ?


#11

Hello,

The Config.report is a big report.

https://allaccess.jikometrix.net/index.php/s/qtmPuvTPjikKXsd
PW: 123456

System Status

installed 1
maintenance
needsDbUpgrade
version 10.1.0.4
versionstring 10.1.0
edition Community