Can't create new files online, can't use online apps

9.1.x
help

#1

Hello,

I installed OC via "softaculous" and created a user "admin" and several "users". File sharing works, so do desktop sync clients, sharing folders via links is allright as well, CalDAV and CardDAV are ok.

What I cannot do is using other apps than mentioned above online and creating files.

Steps to reproduce
1. log into owncloud (https://owncloud..de as a user
2. hit the "+" button near the file path

Expected behaviour
See options "upload", "create folder" and "create file"
Actual behaviour
See options ONLY "upload", "create folder", NOT "create file"

Steps to reproduce
1. log into owncloud (https://owncloud..de as a user
2. "files" app - navigate to *.txt file
3. hit "3 dots"

Expected behaviour
See option for "edit"
Actual behaviour
See options ONLY "upload", "details", "download", "delete"

Server configuration
Operating system: linux
Web server: apache
Database: mySQL
PHP version: 5.4.45
ownCloud version (see ownCloud admin page): 9.1
Updated from an older ownCloud or fresh install: fresh
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):
This message appears every few seconds:

{"reqId":"V5mbqH8AAQEAAGKE3j0AAAAD","remoteAddr":"82.119.1.235","app":"PHP","message":"Module 'memcached' already loaded at Unknown#0","level":3,"time":"2016-07-28T05:44:08+00:00","method":"GET","url":"\/","user":"--"}
{"reqId":"V5mbsn8AAQEAAHRRGb0AAAAh","remoteAddr":"82.119.1.235","app":"PHP","message":"Module 'memcached' already loaded at Unknown#0","level":3,"time":"2016-07-28T05:44:19+00:00","method":"GET","url":"\/index.php\/apps\/firstrunwizard\/wizard.php","user":"herrdeh"}
{"reqId":"V5mbsn8AAQEAAGK8MIIAAAA0","remoteAddr":"82.119.1.235","app":"PHP","message":"Module 'memcached' already loaded at Unknown#0","level":3,"time":"2016-07-28T05:44:19+00:00","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","user":"herrdeh"}
{"reqId":"V5mbsn8AAQEAAGKSe94AAAAQ","remoteAddr":"82.119.1.235","app":"PHP","message":"Module 'memcached' already loaded at Unknown#0","level":3,"time":"2016-07-28T05:44:19+00:00","method":"PROPFIND","url":"\/remote.php\/webdav\/","user":"herrdeh"}
{"reqId":"V5mbsn8AAQEAAGKaTPsAAAAV","remoteAddr":"82.119.1.235","app":"PHP","message":"Module 'memcached' already loaded at Unknown#0","level":3,"time":"2016-07-28T05:44:20+00:00","method":"GET","url":"\/index.php\/apps\/gallery\/config?extramediatypes=1","user":"herrdeh"}
{"reqId":"V5mcP38AAQEAAGLTSKoAAAAG","remoteAddr":"82.119.1.235","app":"PHP","message":"Module 'memcached' already loaded at Unknown#0","level":3,"time":"2016-07-28T05:46:40+00:00","method":"GET","url":"\/","user":"--"}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
subdomain

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

No errors have been found.


#2

Go to demo.owncloud.org, there is no option "create file". There is a third option to create text-files but therefore you need to enable the text-editor (apps-menu).
Why can't you use other apps? What happens with the app store?


#3

Thanks for the quick reply.

OK, I found that the text editor was not installed properly. Could fix that by activating the text editor, and now a user can online edit texts. Great - thx!!

But when I now try to share either a link to the text file, or to the directory which contains the text file, an external user cannot online edit the text file.

In addition:
When trying to share the link and sending it directly via email at the owncloud page, I do get the well-known "Sharing textfile.txt failed, could not find , maybe the server is currently unreachable" error. Tried that with several email addresses.

What can I do?

Cheers,
Wolf


#4

External users can't edit the text file online generally.

For the other issue please create a new thread for the reasons explained here:


#5