Can't create or write into the apps-external directory

I was trying to install owncloud on Ubuntu 18.04.2 LTS, I followed the instructions online and everything was going smoothly. In the finally step I found this Problem

it says that Can’t create or write into the apps-external directory
I tried to fix this problem by
sudo chown -R www-data:www-data apps-external
but it says no such file or directory.

Really appreciate if anyone could solve this problem:)

Try this:



indeed, to sum up you can create the directory by yourself and set the permissions correctly (even if not used, apps-external requires correct permissions for the installation process to end).
FYI, I created a bug report about it and the ownCloud team is working on it.


I am having the same issue and am stuck. I noticed that there was a /var/www/html/owncloud/apps/external directory. Shouldn’t it be using it, instead of the non-existant /var/www/html/owncloud/apps-external directory? Is there a config file somewhere that I can point it the right place?

Check your config.php:

  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/owncloud/apps',
      'url' => '/apps',
      'writable' => false,
    1 =>
    array (
      'path' => '/var/www/owncloud/apps-external',
      'url' => '/custom',
      'writable' => true,

ls -al /var/www/owncloud/apps-external

1 Like

Bear with me, I am new to this. Here is the contents of /var/www/html/owncloud/config/config.php:

<?php $CONFIG = array ( 'instanceid' => 'ocnbvtm2fzca', ); Am I looking at the wrong file? Also, the apps-external directory was never created by the install. It did create /var/www/html/owncloud/apps/external with a bunch of files and directories in it. I installed version 10.4.0. Is the install really that broken that is trying to reference directories that it was supposed to create but didn't???

The code above broke the site altogether. I added this variant and now I can go to the site, but I still get the same error when trying to create admin account.

<?php $CONFIG = [ 'apps_paths' => [ [ 'path' => OC::$SERVERROOT.'/apps', 'url' => '/apps', 'writable' => false, ], [ 'path' => OC::$SERVERROOT.'/apps-external', 'url' => '/apps-external', 'writable' => true, ], ], 'instanceid' => 'ocnbvtm2fzca', ]; Also, I added the app-external directory and it didn't fix the problem.