Can't delete some files and directories

outdated_version
9.1.x
help

#1

I've got uploaded a folder with several big files. In the oc Browser it's not possible to delete the folder and files anymore. I just got a short error "Fehler beim löschen der Datei "XXX"" (error by trying to delete the file…)

The rights are the same then to other files. I can delete the files in my oc-folder on pc and can delete by FTP. But in both cases the files won't disappear in the list of the browser version.

How do I get rid of this files!?!

Operating system: LINUX
Web server: linux
Database: mySQL 5.7
PHP version: 5.5
ownCloud version (see ownCloud admin page): 9.1
Updated from an older ownCloud or fresh install: fresh
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): no encryption

Integrity status for oC9+

No errors have been found.

#2

Hi,

MacOS X is not a supported Operating System for ownCloud:

https://doc.owncloud.org/server/latest/admin_manual/installation/system_requirements.html#supported-platforms

Normally you should get a "Mac OS X is not supported and will not work properly on this platform. Use it at your own risk!" in your admin backend telling you this.


#3

OS X 10.11 is my PC at the office!!!
The Server is LINUX


#4

Hi,

the question in the template is concerning the server. Thats why [b]Server configuration[/b] can be found before these items. So please update the following details in your first post:

Operating system: macOS 10.11 -> Server Operating system is needed here

Web server: linux -> Linux is no Webserver, please name the webserver you're running

PHP version: 5.5 -> Please name the full PHP version

ownCloud version (see ownCloud admin page): 9.1 -> Please name the full ownCloud version

The following is also completely missing. Without the exact infos asked above and matching logentries as explained below its nearly impossible to help here.

[b]ownCloud log (data/owncloud.log)[/b]

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info
[code]

#5

Sorry, I'm not good enough in this stuff to give all this information. I gave all infos as good as I can. :slight_frown:
PHP 5.5 I don't have any more info
oc: 9.1.0 (stable) > don't have any more info

error log:
Cannot set max_execution_time above master value of 45 (tried to set
3600) at /var/www/web12345A/html/datenwolke/lib/base.php#543

`Exception: {"Message":"HTTP\/1.1 423 \"Badminton\" is locked","Exception":"OCA\\DAV\\Connector\\Sabre\\Exception\\FileLocked","Code":0,"Trace":"#0 \/var\/www\/web12345A\/html\/datenwolke\/3rdparty\/sabre\/dav\/lib\/DAV\/Tree.php(179): OCA\\DAV\\Connector\\Sabre\\Directory->delete()\n#1 \/var\/www\/web12345A\/html\/datenwolke\/3rdparty\/sabre\/dav\/lib\/DAV\/CorePlugin.php(285): Sabre\\DAV\\Tree->delete('Badminton')\n#2 [internal function]: Sabre\\DAV\\CorePlugin->httpDelete(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#3 \/var\/www\/web12345A\/html\/datenwolke\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#4 \/var\/www\/web12345A\/html\/datenwolke\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(459): Sabre\\Event\\EventEmitter->emit('method:DELETE', Array)\n#5 \/var\/www\/web12345A\/html\/datenwolke\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#6 \/var\/www\/web12345A\/html\/datenwolke\/apps\/dav\/appinfo\/v1\/webdav.php(56): Sabre\\DAV\\Server->exec()\n#7 \/var\/www\/web12345A\/html\/datenwolke\/remote.php(164): require_once('\/var\/www\/web110...')\n#8 {main}","File":"\/var\/www\/web12345A\/html\/datenwolke\/apps\/dav\/lib\/Connector\/Sabre\/Directory.php","Line":283,"User":"ADDI"}


Cannot set max_execution_time above master value of 45 (tried to set
unlimited) at
/var/www/web12345A/html/datenwolke/apps/dav/appinfo/v1/webdav.php#25 `


#6

Hi,

from the issue template you have filled out:

Before posting please snip make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

ownCloud 9.1.0 is not the latest available version (it is 9.1.1).


#7

The last 3 times I updated oc it totally crashes or had have bugs that I never had bevore. I had to reinstall it and spent hours to this.
Sorry, I'm really sick of the new problems with every update. I definetly won't make a further update this year.


#8

Well, then you won't get any further support in here and i'm closing this issue.

Feel free to create a new thread once you have decided to update to a current version (9.1.1) and the issue still happens there.


#9