Cant enable calendar app


#1

When I click on the enable button I get the error.

"Signature could not get checked. Please contact the app developer and check your admin screen."

So did a load of searching and found

https://owncloud.org/blog/good-bye-apps-owncloud-com/

and put

‘appstoreurl‘ => ‘https://marketplace.owncloud.com/api/v0‘,

in config.php as sugested

Now the productivity and Multimedia sections of the appa are empty(*.

Ben

Server configuration

Operating system: Unbuntu 16.04

Web server: Apache/2.4.18 (Ubuntu)

Database: mariadb 10.0.31-MariaDB-0ubuntu0.16.04.2 Ubuntu 16.04

PHP version: 7.0.22

ownCloud version: 9.1.6

Updated from an older ownCloud or fresh install: fresh

Where did you install ownCloud from:
deb http://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/ /

config.php

<?php
$CONFIG = array (
'updatechecker' => false,
'instanceid' => 'octs9shjkf4o',
'passwordsalt' => 'b4ZA/FCoSNnP+oWBSqqeyQ0UKMkqST',
'secret' => '0MLjeiZnV5dv8Ow26o6YGF+/4DnRJg02GFcZjL92FQbvY81v',
'trusted_domains' =>
array (
0 => '192.168.1.55',
1 => 'prsc-cloud.org',
),
'datadirectory' => '/var/www/owncloud/data',
'overwrite.cli.url' => 'https://192.168.1.55/owncloud',
'dbtype' => 'mysql',
'version' => '9.1.6.2',
'logtimezone' => 'UTC',
'installed' => true,
'memcache.local' => '\OC\Memcache\Redis',
'redis' =>
array (
'host' => 'localhost',
'port' => 6379,
),
'memcache.locking' => '\OC\Memcache\Redis',
'maintenance' => false,
'dbname' => 'owncloud',
'dbhost' => 'localhost',
'dbuser' => 'owncloud',
'dbpassword' => '',
'loglevel' => 3,
'mail_from_address' => 'bene',
'mail_smtpmode' => 'php',
'mail_domain' => 'funkytwig.com',
'htaccess.RewriteBase' => '/owncloud',
'has_internet_connection' => true,
'theme' => '',
);

`


#2

Please have a look at the log file data/owncloud.log ...


#3

Did, it says 'Signature could not get checked. Please contact the app developer and check your admin screen. '. Am I looking for anything else. Its masive. spent a while looking throught it and there does not seem to be mutch in the way of errors. Will see if I can reduce loging errors, purge it and restart.


#4

Maybe you need to uninstall the old calendar app before installing the new one?


#5

It's not a question to disable the old app. It's seems to be a problem on the marketplace itself since about 2 weeks.

In the log :

Server error response [url] https:\/\/marketpla ce.owncloud.com\/api\/v0\/content\/data\/7?version=9x1x6x2 [status code] 500 [re ason phrase] Internal Server Error","level":3,"time":"2017-08-22T16:43:15+02:00" ,"method":"GET","url":"\/owncloud\/index.php\/settings\/apps\/list?category=enab led&includeUpdateInfo=1",
{"reqId":"LyEg+h9nNqIAgCA4SAYV","remoteAddr":"192.168.xx","app":"core","messa ge":"Could not get applications, content was no valid XML","level":3,"time":"201 7-08-22T16:43:16+02:00","method":"GET","url":"\/owncloud\/index.php\/settings\/a pps\/list?category=productivity&includeUpdateInfo=1",


#6

That URL looks wrong ....

A working URL looks like this - https://marketplace.owncloud.com/api/v0/content/data?version=9x1x6x2&categories=1001


#7

I could reproduce this .... :poop:


#8

With your URL, I've no sections on the left panel like productivity and still have the message "Could not get application, content was no valid XML"


#9

It's a server side issue in the marketplace - we will fix this asap ....


#10

The server side fix is being deployed as of now ....